We installed Membership Premium version 3.5.2.8 some months

We installed Membership Premium version 3.5.2.8 some months ago.

Now when we login to Wordpress it is advising that a update to this plugin is available as 3.5.2.9. However, it is advising that to update we have to install WPMU DEV Dashboard. So we installed this, it asks for our username and password, but does not update at all. It says we have to upgrade to update as our WPMU DEV is not valid. On the 20th of Feb 2015 we paid for an Ellite Membership. I see now that Ellite does not exist, and there is something else called Gold Level. Logging to WPMU dev it states that our subscription has been cancelled, so I presume this means we have no valid active subscription.

Can you please advise.