We just started adding memberships to the protected

We just started adding memberships to the protected content. The membership is a free membership and should not end. I have memberships ending and would like it to stop but can't figure out how to accomplish this. Please help.


  • Michael Bissett

    Hey @Michael! :slight_smile:

    A few questions here:

    - What's the membership in question on your site?
    - How long does it take before the membership expires for your users?
    - Are you assigning the membership to each user manually, or is this a public membership that your users are signing up for by themselves?
    - Could you please enable Support Access to your site, so that I can have a closer look at the situation?


    Thanks! :slight_smile:

    Kind Regards,

  • Michael Bissett

    Hey @Michael,

    Checked your settings here, and I'm not seeing anything out of place presently. In regards to this earlier question of mine though:

    How long does it take before the membership expires for your users?

    I reckon I should've worded it better, didn't mean to infer that this was a paid membership. :slight_smile:

    Though it shouldn't be dropping your members like this (since it's a free membership), since it is doing it in spite of that, I'd like to ask how long after a user has registered does this occur?

    I'm doing a test on one of my test sites here, just wasn't sure if it took a few hours, or if it does this immediately. :slight_smile:

    Please advise,

  • Michael

    OK, thanks for clarifying that question. We have been testing and working on this site for a while and it was expiring people at random. Then we upgraded to version and the canceling of memberships stopped. I just recently upgraded to and the canceling came back. It expired my test membership right after I upgraded. So I don't really have a time like within and hour or day.


  • Michael Bissett

    Hey @Michael, thanks for your patience here! :slight_smile:

    I'm only seeing that one user doesn't have a membership presently (username starts with c55), the members that expired previously, did you re-assign their memberships?

    Looking at my own test site, I'm not seeing that the member that I signed up for a free membership has lost his membership. However, I should note that we did release an update to Protected Content yesterday, could you try updating to that, and seeing if that helps things here? :slight_smile:

    Kind Regards,

  • SbOGB-com

    Hi Michael and Michael,
    This is a problem I am experiencing also with new members that I have given free memberships after the last update of the Protected Content plugin. Everything with admin granted membership was working fine until the last update. Now the memberships only last a short time then they show expired. Even though the membership is for a finite time-frame, the new memberships show Active, Expire Never when I reset the membership. Then after a short time (~ 1 day I guess) they go back to expire. All of the older memberships added before the last update are not having problems. I do not use any caching and no other plugins have changed since the Protected Content plugin was working correctly prior to the update. I have been successfully using the plugin since December.


  • Michael Bissett

    Hey @SbOGB-com,

    I see that you've posted over in another thread about this as well, which my colleague @Jude called in the developer on:


    As a general rule, you'll want to open your own thread, instead of posting in someone else's, as there may very well be a different cause for your issue than what the member who opened the thread is experiencing. Which, when it comes to trying to support both of you, can complicate the resolution of a matter.

    If you feel your issue is similar to someone else's, you can link to their thread as you're writing up your question. :slight_smile:

    With that said, we'll want to see what the developer has to say on that thread I linked to.

    Kind Regards,