webpage blocked with message: (see post)

OMG, this is a further website blocked. initiative-integral.org

Now the message is:
Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /hp/az/ad/sl/www/initiative/wp-content/themes/upfront/library/servers/class_upfront_javascript_main.php on line 229

First I uploaded a fresh downloaded file of wpmudev-updates: no result.
Then I uploaded a fresh upfront-builder plugin.
Then I deleted the upfront file hat was in themes. (I made a copy before taking it down.

All did not work.

Please support, yet I get a bit crazy of this happening again and again to websites that have not been updated for a while.

THANKS

Michel

  • Andi

    Hi michel-de

    I hope you are fine
    To see what php version you could create a file i.e. phpinfo.html

    In that file you copy paste the following:

    <?php
    
    // Show all information, defaults to INFO_ALL
    phpinfo();
    
    // Show just the module information.
    // phpinfo(8) yields identical results.
    phpinfo(INFO_MODULES);
    
    ?>

    Then upload the file to your root directory and call it.

    Don't forget to delete the file afterwards or move it to a non accessible folder.

    I hope this helps.

    If you want to have some more comfortable ways of displaying you can check out here: they provide a lot of information:
    http://php.net/manual/en/function.phpinfo.php

    A much better way actually for support staff would be to install the following plugin

    https://wordpress.org/plugins/rs-system-diagnostic/
    it has been tested up to 4.7

    Then reload your backend and go to

    Tools - RS System Diagnostics -
    Now you will see all information a support staff might need to help you!
    There are different ways to send now those information to the support staff.

    1. copy paste the text from the information frame into a post, mail etc (NOT RECOMMENDED!!!! even it would be the easiest way) Always keep security in mind and information in this text can show others also information they better should NOT see!

    2. asking the one who gives support to you and tries to help you for his/her email and than use the form to send all information to her

    3. Do the same like in 2 but send only the link to them provided below the contact form.

    4. RECOMMENDED!
    - Copy the link for the information presented below the contact form.
    - go to WPMU DEV - Support
    - Click on "Get support" or "Grant Support Access"
    - a form will open and yo can give some additional information. Paste that link in there!

    Now the WPMUDEV Support Staff will be able to enter your site prepared with the information you just gave to them and they can help you to fix the problem.

    You can grant them also only the access and than they could install that plugin and get all information and afterwards deinstall it again.

    --
    For the WPMU DEV Support:
    I would recommend to integrate that RS System Diagnostic Plugin to the WPMUDEV Dashboard, so that with a simple click all this information would be added and being visible for your support. I think this would help your support and the user who is perhaps a non developer, if the possibility to send that information would be available directly from within the Dashboard, perhaps even without granting access to the site but with a way "Send Diagnostic Summary to WPMU-DEV" Support Heros.

    This would make it much easier for newbies and non programmers to get help and it would safe a lot of time in searching for a solution which might is caused by some settings which you would see in that diagnostic file. Check it out!

    ---

    Kind regards

    Andi

  • michel-de

    THANKS for that Andi!
    And thanks Predrag.
    As I have no entrance to the dashboard I will have to go Andi's way.

    I created the .html file with that content and uploaded it into the file with the wp installation for that site, where also is the index.html file
    I then called it at initiative-integral.org/phpinfo.html but got a blank page, no error message.
    I might still be doing something wrong then?

    Thanks for any further support.

    Michel

  • Adam Czajczyk

    Hello Michael!

    The file has to be PHP file so instead of ".html" extension it has to use ".php" extension. For example, the file an be called "phpinfo.php" and then you call it this way:

    initiative-integral.org/phpinfo.php

    I just noticed that it was suggested previously to name the file "phpinfo.html" so please rename the file and give it another try and I think this would work for you.

    Best regards,
    Adam

  • Andi

    Hi Michael
    If you can't see the info it can have multiple reasons. One is the naming of the file.

    To check if the file is working you can put a title into the file as this would appear in the browser tab :wink: So you can see if the file gets processed at all.

    i.e.
    <html>
    <head>

    <title>PHP INFO</title>
    </head>
    <body>
    <?php phpinfo(); ?>
    </body>
    </html>

    The solution Adam mentioned would be one. Try to use .php instead of .html

    If this don't help you would need access to your php.ini file.

    check for
    display_errors = on;

    you can set this also in the wp-config.php file. Here it is called: @ini_set( 'display_errors', 1 );
    to output a file instead you could enter the following. It would write a log file.
    /* WordPress debug mode for developers. */
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    #define( 'SCRIPT_DEBUG', true );
    #define( 'SAVEQUERIES', true );

    here the following things could be missing or placed in:

    disable_functions = phpinfo;
    there could be more then one function standing in that line!
    -> try disable_functions = ; (fill it in at the end of your php.ini)

    This directive allows you to disable certain functions for security reasons. It receives a comma-delimited list of function names.
    This directive is *NOT* affected by whether Safe Mode is turned On or Off!!!
    some hosters are disabling phpinfo too! so check with them and better CHANGE to another if they don't allow that as you will need it for sure more then one time :wink:

    Those having ssh access try

    php -i

    or

    php -a
    this will get you to the interactive php shell and enables it.
    I`nteractive mode enabled
    php > phpinfo();
    phpinfo()
    PHP Version => 7.0.8-0ubuntu0.16.04.3`

    or

    $ cat php.ini | grep -in "disable_function"

    it will utput the list of all disabled functions. Edit the php.ini and delete the "phpinfo"
    and restart apache / apache2 i.e. with service apache2 restart

    Also the following could have been set in your apache config file or .htaccess

    <FilesMatch ".+\.ph(p[3457]?|t|tml)$">
         # SetHandler application/x-httpd-php
    < /FilesMatch>

    --
    but to display the phpinfo you would need ... without the hash sign

    <FilesMatch ".+\.ph(p[3457]?|t|tml)$">
         SetHandler application/x-httpd-php
    < /FilesMatch>

    Attention also here "SetHandler" might be not possible depending on your host!

    If you still see a blank page and can't get to the other information try to upload another simple .php file i.e.

    hello.php
    <?php echo "Hello, world."; ?>

    and
    hello.html
    <h1>Hello, world !</h1>

    If you have cPanel at your hoster use
    https://www.namecheap.com/support/knowledgebase/article.aspx/9397/2219/how-to-check-php-version-and-configuration

    With the following scripts yu also can check the compatibility of your server to host wordpress!
    https://github.com/AbhishekGhosh/WordPress-Server-Compatibility-Checking-Script

    and for those looking to check their database connection this will help:
    https://gist.github.com/chales/11359952

    ---
    For WPMUDEV Team
    It would be good to update the links here and link them to working scripts
    https://premium.wpmudev.org/blog/daily-tip-how-to-check-if-your-server-is-ready-for-wordpress-3-2-requirements/
    It is an old article but still google finds it and people probably will find it too and get frustrated if the links don't work. Better would be to simply update that specific article also for the current Wordpress Version - it is actually only a very short one. :grinning:

    ---

    Thanks

    Andi

  • Andi

    Here are the files I mentioned above.

    As I can't upload .php here you would need to remove the .txt part from those files!

    Don't forget to set user / group and permissions correct as also this can cause a white page or access error.

    HMM I give up! - sorry I can't upload those files - Please WPMUDEV please provide a GIT repository so stuff like that could be uploaded there instead at a centralized WPMUDEV place. Thanks!

    Andi

  • Predrag Dubajic

    Hi Andi,

    Thank a lot for helping out here, this is some really useful information, I'm sending some thankyou points your way :wink:

    Our system currently only allows uploads of text and image files for users, you can always use file sharing service like DropBox or GDrive and share download link.

    Article you mentioned above is quite outdated but I'll check with our content writers to update it with new info since it is still well indexed by search engines. :slight_smile:

    Best regards,
    Predrag

    • Andi

      Wow michel-de - that is stone-age PHP - If your hoster hasn't updated PHP since then - many years ago, then I would recommend in changing completely to another hoster as it shows it is a clear sign that this hoster does not care about the web-application hosted on its servers, and he probably also won't have an actual OS up and running. I would recommend checking that too - what OS he is running on his servers and what apache version and other software versions.

      Kind regards

      Andi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.