Website content different for Mobile than for PCs

Hi

I found out a very strange behaviour that one of you guys might be able to explain or help me solve it.

I just launched a new blog http://whatsnewinsiliconvalley.com which works well on PC and Mac but for some reason which baffles me the content displayed on the iPhone or any mobile I suppose is not up to date. It displays a very old post.

And that happens only for the home page. The content can be access directly without a problem from the iPhone http://bit.ly/yI091z

Any idea what I should do?

  • Timothy
    • Chief Pigeon

    Hey tapuat.

    I just went to have a look through my Mac, iPhone and other mobile but it seems your site is down:

    This website is currently unavailable.

    If you are the web hosting account owner, please contact our customer service department.

    Our customer service center is available 24×7 via phone, chat, or email:

    Hope everything is OK.

    Let us know when its back up, I’m sure we could have a look then. :slight_smile:

    Take care.

  • Timothy
    • Chief Pigeon

    Looks like some theme setting to me.

    Knowing Elegant Themes (which is your mobile and site theme) there will be an option to decide what category and content to display.

    Have you checked the Elegant Theme settings to see if there is something there?

    Let me know :slight_smile:

    Take care.

  • tapuat
    • Design Lord, Child of Thor

    Hi Tim :slight_smile:

    Yes I checked that first and there is no variable to set related to that topic.

    More importantly there is no post Hello World on that site anymore (I deleted it).

    My logic (if i am correct) would be that it is an issue with Domain Mapping?

    This site shares a MultiSite install with others.

    Although the other domains do not have the issue at hand so I don’t get it :wink:

  • Timothy
    • Chief Pigeon

    Do you have any cache plugins running like WP Super Cache or W3 Cache?

    Either way, please diable all your plugins and then test again. If the issue is still there, revert to the default Twenty Eleven theme.

    If the issue goes away then reactivate each one, one by one whilst testing again until the problem crops up.

    This will eliminate plugin or theme issue/conflict.

    Let me know how you get on. :slight_smile:

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.