Website is running really slow especially in WP dashboard

The customer keeps complaining every day that things are taking ages to load in the dashboard. He has run Hummingbird and Smush Pro a few times but it is not helping. Please could you have a look and see if there is anything we can do to improve performance on this site please?

  • Nithin
    • Support Wizard

    Hi Jessica,

    Hope you are doing good today. :slight_smile:

    The customer keeps complaining every day that things are taking ages to load in the dashboard.

    Is the issue only specific within the dashboard side? It seems like the support access to your site is disabled at the moment, so I wasn't able to give much closer look regarding that.

    Hummingbird Pro, and Smush Pro plugins will only help with improving, and optimising the webisite in the frontend, I could notice there could be some improvements that could be done in the frontend side, however I'll have to 1st check what all settings have been enabled in both the plugins to have a better idea on what to suggest further.

    Could you please grant support staff access so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access, so that we could get this sorted. Have a nice day ahead. :slight_smile:

    Kind Regards,
    Nithin

  • Luís
    • Support

    Hi Jessica ,

    Hope you're doing well today :slight_smile:

    I gave a closer look on your site and the WordPress admin dashboard doesn't seem slow to me, I got load times between 3s and 5s, what is expected.I just gave an overall look, did you experienced a slowdown in any specific page?

    Regarging to the front-end, and based on the browser console, you are getting a Javascript error that comes from the map:

    Uncaught TypeError: Cannot read property '__e3_' of undefined

    From what I checked, the map is a feature from Divi theme, I may suggest you to try contact them to check if they have any similar report or fix.

    Also, you are getting a 404 error (not found) in an image: https://g***ical.co.uk/wp-content/uploads/2018/04/dots.png

    I was not able to identify from where this image comes, maybe you have clue? However, I would strongly recommend you to try fix these issues, because they are increasing the page load times.

    Beside the issues pointed above, I also made a Performance Test on Hummingbird and got the following recommendations:

    1) Optimize Images

    If you expand the Optimize Images section, you will see recommendations for Compressing and resizing the following images:

    /wp-content/uploads/2018/05/Book_mockup_DIETS.jpg
    /wp-content/uploads/2018/05/Book_mockup_SMARTER.jpg
    /wp-content/uploads/2018/05/Book_mockup_winning.jpg

    Compressing and resizing means the image is not using a proper size to fit into the container and it's being resized via HTML or CSS, what is a bad practice. To easily solve this issue, I may suggest you to enable CDN option on Smush (Smush -> CDN) and make sure you have Enable automatic resizing of my images enabled too.

    2) Remove render blocking resources

    Regarding to this recommendation, you can use Asset Optimization feature from Humminbgird:

    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#chapter-4

    Will also suggest you to give a look on this reply from my teammate Dimitris, I believe its very well explained what is the render blocking issue and how can you try solve it using Hummingbird:

    https://premium.wpmudev.org/forums/topic/hummingbird-remove-render-blocking-javascript#post-1319581

    I hope this information has been helpful. If I can help you in this or other related question, please let me know!

    Cheers, Luís

  • Zeun Digital
    • WPMU DEV Initiate

    I've implemented a few of your suggestions and got a bit of an improvement in the performance report. Will need to experiment with the asset optimisation.

    However the main issue is when editing a post and switching to the front-end builder in Divi it takes a long time to load the page.

    I will raise a ticket with elegant themes too in case this is a specific divi problem.

  • Luís
    • Support

    Hi Jessica ,

    Hope you're doing well today!

    I am glad the suggestions helped in improving the performance of your site :slight_smile:

    Regarding to Divi builder issue, I tried to check this, but seems the Support access is not open anymore. I don't have too much experience with Divi Builder, but as a page builder it may take some time to load all its features, but as I was not able to access, can't say if there is any anomaly. If you are interested, can you please re-enable the Support access, so I can give a look?

    However, as you will contact their Support, I am pretty sure they will help you better on it, as they know better the code involved.

    I hope this information has been helpful. If I can help you in this or other related question, please let me know!

    Cheers, Luís

  • Zeun Digital
    • WPMU DEV Initiate

    Hi Luis

    I have granted support access to the site again and would be grateful if you could take a look at the Divi Builder issue.
    The fonts are also now not loading properly so I may need to reverse some of the changes I have made in asset optimisation.

    Thanks
    Jessica

  • Nithin
    • Support Wizard

    Hi Jessica,

    Hope you are doing good today. :slight_smile:

    However the main issue is when editing a post and switching to the front-end builder in Divi it takes a long time to load the page.

    Is there any specific steps regarding this that should be followed? I tested with couple of random pages, and the frontend Divi Builder seems to load fine without much delay.

    However, I could notice when I try to edit the post in the dashboard, it does take time for Divi Builder to load. However, this seems more specific with not having enough server resources.

    There are couple of improvements that you could perform, however it'll require asking your hosting provider to make the changes.

    I could notice that the site is running on PH 5.6.40. Would highly recommend you to ask your host to switch to PHP 7, or greater versions.

    PHP 7 is very fast compared to version 5.6, and it should improve the overall performance of your site.

    Other aspect is the server resources, just to be sure, could I know how the memory limit is increased in your site? Is it by adding the following code in wp-config.php?

    define( 'WP_MEMORY_LIMIT', '1024M' );

    If yes, could you please create a file called info.php inside the root folder, and add the following code in it:

    <?php phpinfo(); ?>

    Once done, load the info.php file in the browser address bar by typing the following:
    your-site-url.com/info.php

    Which should load the PHP Info page, please double check whether the value of memory_limit in the listed page, has 1024 as the memory limit or not?

    It doesn't seem like that's the case, would highly recommend asking your host to change the server resources, to at least the following values:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300

    And check whether it makes any improvement regarding the dashboard being slow around loading Divi.

    If you still have issues even after that, then Divis support would be able to provide a better idea too.

    Please do let us know how that goes, have a nice day ahead. :slight_smile:

    Regards,
    Nithin

  • Zeun Digital
    • WPMU DEV Initiate

    I have attached a screenshot with the PHP settings that I have set on the server. I did not change the memory limit as that was already set to the maximum at 1024mb.
    The most I can set for post max_size is 128mb. All the others are within the figures you suggest. See attached screenshot of CPanel settings.

    I have also created the info file here:
    http://getphysical.co.uk/info.php

    I will ask the user to test the dashboard again and let me know if there is an improvement.

    Many thanks for your help
    Jessica

  • Zeun Digital
    • WPMU DEV Initiate

    Just tried it this morning and it looks a lot quicker. Save time for a new draft post was only 10 seconds. The longest wait was opening ‘build from the front end’, which took about 30 secs to open fully. But other than that, it seems much better.

    Ran another hummingbird test and for some reason, it dropped to 54 and 59 on a second! Everything else has gone green except server time, which dropped to only 25, yet that didn’t seem an issue.

    I cleared my browser cache and opened the site as usual and the load time seems anywhere from 6-12 seconds depending on the page (some were pretty quick, others seemed slower to fully load) but as soon as I clicked on a new page there was an immediate change, whereas before it would hang for a few seconds before anything happened.

  • Nithin
    • Support Wizard

    Hi Jessica,

    Sorry for the delay in getting back to you, I checked the info.php file, and now PHP seems to be updated to v 7.2.x, and the memory limit do look fine.

    Sounds like the dashboard is loading fine now? If the issue is still ongoing, then other steps you could consider is implement Object cache. You could use plugin like W3T Cache plugin to enable it.

    If using W3T Cache, would recommend you to disable Hummingbirds Page Cache, as you could enable all the cache features via Hummingbird.

    You might find the following article helpful:
    https://onlinemediamasters.com/slow-wordpress-admin-panel/
    https://wpbuffs.com/slow-wordpress-dashboard/

    I hope this helps further, have a nice day ahead. :slight_smile:

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.