Website Keeps going down Socket Timeout

My website keeps crashing for some random reason. I've enabled support on it, please take a look.

Thank you for your help.

  • Sohag Ronjon Dey
    • Support

    Hi Brandon,

    Thanks for contacting us and I hope you are having a beautiful day! :slight_smile:

    It will be helpful for us if you mention exactly the steps when the site crashes. Does it crash on navigating to any particular page? When did the crash first started occurring? Is it started crashing after installing any plugin or your theme?

    We would recommend you to enable debug mode in your site which will log the errors in a file in your sites backend and will help us to have a better idea.

    To enable debug mode, open your wp-config.php file located in your root directory, and look for

    define( 'WP_DEBUG', false );

    replace it with:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    This will log the errors and prevent to show the errors on the front end.

    Once done open the site and when it crashes find the debug.log at /wp-content folder and send it to us.

    We will look forward to hearing from you.

    Cheers,
    Sohag

  • Brandon
    • Site Builder, Child of Zeus

    The website is crashing all the time for no apparent reason. I am not visiting it at all, and I am just receiving Defender notifications that it goes down 10+ times a day sometimes for a few minutes at a time.

    I've contacted your live chat to provide the error log.

    Thanks

  • Sohag Ronjon Dey
    • Support

    Hi Brandon,

    Thanks for contacting and I hope you are doing well today.

    Will you please contact your hosting provider and ask them to increase
    1. max_allowed_packet size setting for mysql
    2. max_execution_time of query

    While they do the changes will you please perform a basic theme/plugin conflict test? To perform it try to temporarily deactivate all plugins. Then enable the plugins one by one to see if the error generates. In this way we will be able to find out the conflicting plugin if there is any.

    Please visit the following article to follow the steps of conflict test (you may need to scroll the page down a little):

    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    or follow the steps in the flowchart.

    If increasing mysql packet size does not work then please take your sites backup and grant support access and send us your ftp credentials so we can take a closer look at your end?

    You can grant support access via

    Dashboard - WPMU DEV -> Support -> Support Access -> Grant Access or

    by following this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please send us your ftp cridentials through our contact form,

    https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Sohag"
    -WordPress admin username
    -WordPress admin password
    -login url
    -cpanel credentials (host/username/password)
    -ftp credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me

    Please DO NOT post the credentials here as this is a public forum, also would you mind me doing some basic troubleshooting such as temporary deactivating all plugins?

    Let me know when you do so!

    Cheers,
    Sohag

  • Brandon
    • Site Builder, Child of Zeus

    It's a shared hosting environment so those factors can't be changed at all.

    I use the exact same plugins and themes on 50 different instances of my reseller hosting account on the same server, and none of those websites have this problem.

    I've submitted the login details requested and activated remote support.

    Thank you

  • Sohag Ronjon Dey
    • Support

    Hi Brandon,

    Thanks for the support access and the credentials.

    The debug log suggests that some of your sites code is making several requests at once as a result exceeding the maximum connection limit. Also there are some deprecated codes in any of the plugin or in theme. Perhaps a theme/plugin conflict test may help us to determine which code is creating the issue. Have you performed the theme/plugin conflict test? If not will you please perform the conflict test. Please follow the flowchart and link I have mentioned earlier. If you like and allow us then we will do the conflict test for you.

    Please let us know.

    Cheers,
    Sohag.

  • Sohag Ronjon Dey
    • Support

    Hi Brandon,

    Thanks for the reply and hope you are doing well! :slight_smile:

    I have performed the plugin conflict test. At first I have activated the maintenance mode. I have disabled all your plugins and activated one by one and I have found no error is showing. One of the plugins I have not activated that is revslider. It is asking for update. I have also disabled the Really Simple SSL plugin. Please enable it if is necessary. Which was making the admin login page hidden. During this period the site has not crashed. The debug log is still enabled and let me know if it crashes at your end again. Then it will be shown on the debug log which I will forward to our developer for their response.

    Please also update the two plugins Yoast SEO and Revslider to their latest versions. Sometimes updates of plugins/themes/wordpress solves a lot of issues.

    I will look forward to hearing from you.

    Cheers,
    Sohag

  • Sohag Ronjon Dey
    • Support

    Hi Brandon,

    Hope you are doing well today! :slight_smile:

    I have performed scan in the defender in your site and it was suggesting 10 security tweaks. I have configured it so now it is showing 0 issues in the dashboard. Please check if the crash issue occurs again and please let me know then I will flag this to our developer for their response.

    Cheers,
    Sohag

  • Predrag Dubajic
    • Support

    Hi Brandon,

    Apologies for the delay here, your issue seems quite complex and specific to your installation.

    Most of the fatal errors from the log are referring to memory limit being hit, you mentioned that you can't adjust max_allowed_packet and max_execution_time, but is it possible to bump your site memory limit to at least 256M and see if it works properly after that?

    Also, I see error about wp_is_file_mod_allowed which could be happening because of incorrect update to WP 4.8 and it's suggested to manually re-install WP 4.8 files to see how it behaves after that.
    You can do that by downloading WP installation from wp.org and replacing your current files with new ones, just make sure you leave old wp-content folder as well as wp-config.php and .htaccess files.

    Best regards,
    Predrag

  • Brandon
    • Site Builder, Child of Zeus

    Thank you for your reply.

    I have done both, so let's see what happens. The website is still running extremely slow though, and I think that may be related to the issue we're experiencing, so please let me know if you have any ideas about how the 2 issues may be solved, or advice on speeding it up based on what you know of this site.

    Thank you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.