Website Performance bad

My website performance is bad. Installed Humminbird - but Remove render blocking resources is 39. When I click on it to improve - it doesnt work and I have following error at bottom of page: Fatal error: Uncaught Error: Unsupported operand types in /home/blog4col/public_html/wp-content/plugins/wp-hummingbird/core/class-utils.php:686 Stack trace: #0 /home/blog4col/public_html/wp-content/plugins/wp-hummingbird/admin/class-dashboard-page.php(585): WP_Hummingbird_Utils::human_read_time_diff(Array) #1 /home/blog4col/public_html/wp-content/plugins/wp-hummingbird/admin/views/meta-box.php(31): WP_Hummingbird_Dashboard_Page->dashboard_browser_caching_module_metabox() #2 /home/blog4col/public_html/wp-content/plugins/wp-hummingbird/admin/abstract-class-admin-page.php(125): include('/home/blog4col/...':wink: #3 /home/blog4col/public_html/wp-content/plugins/wp-hummingbird/admin/abstract-class-admin-page.php(295): WP_Hummingbird_Admin_Page->view('meta-box', Array) #4 /home/blog4col/public_html/wp-content/plugins/wp-hummingbird/admin/views/wphb-page.php(11): WP_Hummingbird_Admin_Page->do_meta_boxes('box-dashboard-l...':wink: #5 /home/blog4col/public_html/wp-content/plugins/wp-hummingbird/admin/abstract-class-admin-page.php(125): incl in /home/blog4col/public_html/wp-content/plugins/wp-hummingbird/core/class-utils.php on line 686

  • Nithin

    HI Vea,

    Hope you are doing good today. :slight_smile:

    Render Blocking is something which is correlated, and entirely depends upon the theme, and how it honours the minification settings, configured under Hummingbird > Asset Optimization page.

    It's odd that you are getting the above fatal error, when you try to improve it. Seems like the support access isn't enabled in your website, so I couldn't say much about what could be causing this without giving a look at the dashboard.

    To double check whether there isn't any conflicts, could you please run a conflict test as mentioned in this flowchart, and see whether you still see the same Fatal error, or not?

    FlowChart:
    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    If the issue still exists even after running a conflict test as above, then please enable support access to your site, so that I could give a closer look at it.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access, so that we could get this sorted. Have a great day ahead.. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska

    Hello Vea,

    Our developer checked your site and was able to get rid of that nasty error there, so Dashboard of Hummingbird is now working fine.
    If this will show up again please post steps that were done before error showed so we could try to pinpoint why it is occurring.

    Thanks. i did checkout the list, Im not sure what to turn off b/c I use all the themes on my multisite -

    In the case of the Multisite, Asset Optimization needs to be done for each subsite separately. So Super Admin or subsite Admin will only see files used on this particular page.
    There is no one Global page to configure that.

    Advanced Asset Optimization is described here https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#chapter-4
    Most important thing is:

    The most important thing when working with Advanced mode and making changes to how your site loads files is that you test things out after every single change.

    It is not recommended to select all your files, click on Bulk Update, and enable all of the options at once. This could have disastrous consequences for your site, and break a lot of things! Please do not do this!

    You won’t be able to apply every option to every file, so it is very important to test as you go. (and make sure to click on Save Changes beforehand!)

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.