Website speed

Hello, My website has slowdown over the weekend .https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Fnewslink7.com%2F

Ensure text remains visible during webfont load
Warnings: Lighthouse was unable to automatically check the font-display value for the following URL: https://newslink7.com/wp-content/themes/mh-magazine/fonts/fontawesome-webfont.woff2.

  • Adam Czajczyk
    • Support Gorilla

    Hi JB.LAMADRID

    I hope you're having a nice day today!

    PageSpeed score for desktop is currently at about 92 level (that might vary a few points up or down from test to test, that'd be perfectly normal thing) so I'd say it's really good. I don't know, however, what was previous desktop/mobile score - could you tell me, please, what is the difference?

    Ensure text remains visible during webfont load
    Warnings: Lighthouse was unable to automatically check the font-display value for the following URL: https://newslink7.com/wp-content/themes/mh-magazine/fonts/fontawesome-webfont.woff2.

    In general, this means that PageSpeed test wasn't able to find out whether the "font-display" is even set on site which might be result of a couple of things: it might not be set at all, the FontAwesome CSS might not be fetched/parsed properly by Google PageSpeed (often due to it being inlined) or FontAwesome is loaded but actually not used on the homepage (as it's only homepage that's checked).

    That's usually one of the issue above. I don't see any optimization (so CSS inlining too) currently configured in Asset Optimization in Hummingbird though so unless you're doing it in some other way (via some other plugin or some theme options) I think CSS inlining is not an issue here, which leaves the two other options as possible culprits.

    Can you tell me please if that particular recommendation was showing up for you before or it started to show just recently (like over the weekend for example) and if you did make any changes whatsoever to the site configuration recently?

    Best regards,
    Adam

  • JB.LAMADRID
    • WPMU DEV Initiate

    Thank You I was referring to Mobile I apologize, Mobile up to Friday was running between 80 to 87. Before joining your company Mobile was 80 to 87 desktop between 97-99.
    On Saturday I contacted your company for help with a plugin as well as disconnecting your company SEO since I have paid version of Yoast.
    The Gentleman was very helpful. If we can fix the speed back to were it was, I would greatly appreciate it.
    Desktop speed today is fine 99

  • Predrag Dubajic
    • Support

    Hi JB.LAMADRID,

    There was a console error regarding jQuery on your site and I've resolved this by excluding the main jquery from minification in Fast Velocity Minify plugin, however I do see that this plugin also has some Google Fonts settings so you might want to try tweaking the options there.
    I'm not familiar with Fast Velocity Minify plugin so I'm not sure how it works and if any of its settings could be improved here.

    What I can suggest is trying to setup Asset Optimization in Hummingbird directly, it might take longer time as each file can be configured individually but this kind of optimization offers the most control and once fully configured it should be giving the best results.

    One more thing in your console is a missing image in your media folder:
    /wp-content/uploads/2019/03/newslink7_400x400.jpg
    When you load the site the browser will do extra work to try and fetch the missing image so that will affect the score as well so I would suggest checking what happened with that image and try re-uploading it.

    Best regards,
    Predrag

  • JB.LAMADRID
    • WPMU DEV Initiate

    Hello, I appreciated it, however, the speed is now mobile @ 60 I Repeat before Saturday and before joining your company for months my mobile speed was between 80 plus.
    Please see what occurred on Saturday with the tech from your company who was very helpful.
    I ask for my SEO that comes with wpmudev be discontent since I had Yoast.
    After that, the low score start.
    It is very concerning, Please I need this fixed.
    Will not be available today until 2 pm (est)
    PlEASE DO NOT UPDATE 2 plugins that I have classic editor, and Blogs2social leave as is.
    Below you will see the mobile test that I ran as I responded to Ticket, I appreciate your help.
    https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Fnewslink7.com%2F
    First Contentful Paint
    3.4 s
    Speed Index
    4.4 s
    Time to Interactive
    7.3 s
    First Meaningful Paint
    4.2 s
    First CPU Idle
    5.9 s
    Max Potential First Input Delay
    210 ms
    Eliminate render-blocking resources
    1.37 s
    Serve images in next-gen formats
    1.18 s
    Defer offscreen images
    0.9 s
    Remove unused CSS
    0.15 s

    Ensure text remains visible during webfont load
    Warnings: Lighthouse was unable to automatically check the font-display value for the following URL: https://newslink7.com/wp-content/themes/mh-magazine/fonts/fontawesome-webfont.woff2.
    Leverage the font-display CSS feature to ensure text is user-visible while webfonts are loading. Learn more.

  • Predrag Dubajic
    • Support

    Hi JB.LAMADRID,

    I ask for my SEO that comes with wpmudev be discontent since I had Yoast.
    After that, the low score start.

    If I understand this correctly the issue started when you switched to Yoast SEO, is that correct?

    Did you try disabling Yoast and running a new test to see if that is what is causing the issue with the speed?

    I'm just trying to catch up what exactly happened here because from what I see, the changes Patrick was helping you with in chat mostly had to do with Yoast and Blog2Social.

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi JB.LAMADRID,

    Apologies for the delay here, we're working on the tickets from the oldest response to newest so each response was pushing your ticket at the end of the queue.

    I just did a post-Yoast is Not Working?
    It was working 15 minutes ago/
    Did you disconnect it?

    I didn't made any changes on your site, I was just checking what is installed there and how it's set up, we would always ask for permission to make changes on members sites, or ask you to do the changes/test your own.

    Hello, I have insult 3 plugins my speed now is at 80 mobile

    Could you elaborate this a bit more, you disabled 3 plugins and the speed is good again?
    Can you tell me which plugins were those?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.