Website speed improvement quest

Pingdom give me a F for
The requests for the following URLs don't fit in a single packet. Reducing the size of these requests could reduce latency.
data:application/x-font-woff;charset=utf-8;base ... AAAB//8AAnjaY2BgYGQAgosrjpwF0ZcUq9bCaABTzgdAAAA=

GT Metrix F grade
Enable compression for the following resources to reduce their transfer size by 91.5KiB (72% reduction).

What .htaccess settings do I have to set?
How can I solve this?

  • Nithin

    Hi Renaat,

    Hope you are doing good today. :slight_smile:

    What pingdom shows is more of a suggestion, Google page speed doesn't recognizes it as a problem.The mentioned files doesn't increase the server load, enabling Gzip compression, and minification should have removed the notice from pingdom, but it doesn't seem to make any difference in your system, maybe it's a minor glitch.

    If you are looking to troubleshoot this further, if possible, could you please reset the Hummingbird settings, and please check whether re-configuring the settings, makes any difference.

    Please do note that, resetting the Hummingbird settings, will clear all the settings. You'll have to enable, and configure everything from start.

    Kind Regards,
    Nithin

  • Rupok

    Hi Renaat,

    The requests for the following URLs don't fit in a single packet

    I searched with this issue and found that JetPack genericons enqueuing is causing this. To resolve this, you will need to deregister and dequeue genericons script and you can do that by creating a MU Plugin. For creating a MU Plugin, create a folder named "mu-plugins" inside your "wp-content" folder. Then inside that "mu-plugins" folder, create a file with any name and with a .php extension. Now paste the code inside that file and save.

    <?php
    function stop_loading_genericons() {
        if ( wp_style_is('genericons', 'registered') == TRUE) {
            wp_dequeue_style( 'genericons' );
            wp_deregister_style('genericons');
        }
    }
    add_action( 'wp_enqueue_scripts', 'stop_loading_genericons', 999 );

    For getting more idea on mu plugins, you can go through this article: http://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins/

    This should resolve your first F grade. If it doesn't, please let us know. We will be glad to assist further.

    Enable compression for the following resources to reduce their transfer size

    As you said you are using a shared server and your server is using NGINX, you should ask your host regarding how you can enable GZip Compression in your server. You can forward them the information shown in "Dashboard > Hummingbird > GZip Compression" section. Please check the attached screenshot for reference.

    When they turn on GZip for your account or server, you can use the full power of Humming GZip Compression and with this feature, you can resolve your F grade.

    Please let us know if you have any confusion. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.