Weird Snapshot directory setting bug?

Just FYI and if anyone wonders same thing, there is a bug when trying to set settings if the Snapshot is already installed and working:

If changing any settings and leaving the option of the Snapshot directory to the "Default" error message is shown that "Snapshot directory already created". One need to change setting to the custom and then the settings will be saved. Custom puts directory to the same as default:
"Your current snapshot directory lives at: ...../www/wp-content/uploads/snapshots/"

Weird bug.

  • James Morris

    Hello Niko Paulanne,

    I hope you are well today.

    I've just checked this on a fresh install of WordPress 4.9.4 with Snapshot Pro 3.1.5. I changed every setting on the WP Admin -> Snapshot -> Settings page except the Local Directory setting. I was not able to reproduce this bug. Even after changing this setting and reverting it back to default, the error never displayed.

    I then repeated this process on a site that has had Snapshot Pro installed and running for several months. Again, I was not able to reproduce this error.

    There's a couple troubleshooting steps I'd like you to try to see if we can narrow down the cause of this problem.

    First, could you please run a plugin conflict test to eliminate the possibility of a conflict with another plugin?

    Whenever you perform a plugin conflict test, it's always better to do so on a staging site. You can learn how to create a staging site here.

    The simplest way to perform a plugin conflict test:
    * Login to your site via FTP
    * Navigate to wp-content
    * Rename the plugins folder to _plugins
    * Create a new plugins folder
    * Move the plugin folder (ex: snapshot) you want to test from _plugins to plugins
    * Then, one at a time, move other plugin folders over from _plugins to plugins until the symptom returns

    NOTE: While you are doing this, do not visit WP Admin -> Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    If that does not lead to a solution, could you please enable WP_DEBUG and provide us with the output of your debug.log file?

    To enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    After you've visited the pages that are causing you problems, please go to wp-content/ on your server via FTP and download the debug.log file to your local computer. Then, open that file with a text editor like notepad (Windows), GEdit (Linux), or TextEdit (Mac). You can then save the file as a .txt file and upload it here as an attachment to your post.

    I look forward to seeing the results of your tests.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.