What are the browser requirements for Upfront?

What are the suggested minimum browsers I should be using for Upfront to work properly?

I'm working on an old laptop running Mac OS X 10.5.8. My browsers are pretty old, too: Firefox 16.0.2 and Safari 5.0.6.

Upfront isn't working properly on either browser - in various ways it's non-responsive or poorly responsive.

Thanks,
Dan