what can i do when this happens after nstalling the plugin on a non Mu wp install

ok so i did not read up on this plugin as much as i should have. i installed it through wp plugin installer on a non multi site. now i get this message every time i try to view my plugins "The Dashboard Widget Order plugin is only compatible with WordPress Multisite." so i did what i normally do when a plugin fails or locks my admin up, i ftpd my plugin folder expecting to find the folder for this plugin, however it is not there.