What causes the plugin folder not to come through in Snapshot?

Hey,

I enabled wpmudev dashboard support FYI too.

What cause the plugin folder not to come through in Snapshot?

See here:
http://screencast.com/t/Y0jq4B1g6

I need a exact and 100% cloned snapshot to migrate this site. I know I selected everything. What would cause the plugins folder to not be present in the .zip?

Can you take a look? Keep in mind knowing we really need this snapshot to be 100% identical on the other site we restore to.

Another Snapshot can be done on the server FYI too if you want to test it.

Thanks.

P.S. Side Question: The other site had information on it (pages and posts etc). We are going to be sure that the theme active and all plugins are active before the migration/restore from the snapshot too of course, but my question is when we do that all the old pages and posts and info will be deleted/removed right (which we are totally fine with as long as the other site looks and has the exact same content, settings, look/feel etc)? I.E. it will be truly restoring the previous site 100% from that (cause we do not want to have duplicate pages and posts or other such issues)?

  • Rupok

    Hi Greg, hope you had a wonderful day.

    Thanks for granting Support Access. I logged in to check your configuration. They seems to be ok. But still, can you select "Include common files: Themes, Plugins, Media (wp-content/uploads)" while creating the snapshot? Please check the attached screenshot for reference.

    I tried to create a snapshot to test the issue but when it's 60% done, it showed me the following error:

    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
    Additionally, a 503 Service Unavailable error was encountered while trying to use an ErrorDocument to handle the request.

    So I could not test it. Can you please try the way I suggested above and let us know the result? I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Greg

    Rupok and team,

    wpmudev dashboard support is still enabled FYI.

    A bit urgent FYI . . .

    Thanks. But I did that before that you mentioned. So, I just ran a fresh one again. See:

    http://screencast.com/t/WiGmmOYk (selected all database tables too) and http://screencast.com/t/6VnHgZkA

    Look at the most recent I ran and click "edit" to see the exact settings I used.

    It is not picking up the Plugins.

    How can we fix this asap?

    We really need to move this soon!

    :slight_smile:

    Greg

    P.S. When setting up, I do not think the Plugin database information is there either? What do you see during selecting all the tables and seeing the plugins we have that should be there? So, it appears that even though we select Plugins in the "What files to archive" settings, the folder and databases are not showing as available or something?

  • Nastia

    Hello Greg

    Please send your credentials to us!

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Nastia"
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    We are waiting for your email!

    Cheers,
    Nastia

  • Nastia

    Hello Greg

    Thank you for sending your credentials.

    I have tested every possible reason for this issue, however, the are no errors to tell us that something is wrong.

    I have reported this to our second level support so they can have a look, I have passed your credentials as well, so please don't change the yet. Please note the developer response will take longer than usual, because this task it's complex.

    In the meantime, I believe we still can try to increase the max_execution_time from 30 to 300.

    Locate php.ini file inside the site's directory and place the following code there:
    max_execution_time = 300

    If there is no php.ini file, please create one.

    Also, please check the Error Log on your cPanel for any errors that might have occurred.

    Let me know if you find anything.

    Kind Regards,
    Nastia

  • Greg

    Hey,

    I am circling back . . .

    There are no cpanel error logs to speak of regarding this.

    I tested running Snapshot on the this same server on a ROOT WP install and it worked fine.

    The one with the issue is in a subfolder one level deep from the ROOT on the same sever FYI and it is not working (i.e. does not produce the plugins folder etc).

    I just created a php.ini for this subfolder install and put it in wp-admin(I added the following):

    upload_max_filesize = 1000M
    post_max_size = 2000M
    memory_limit = 3000M
    file_uploads = On
    max_execution_time = 300

    I even tried renaming the file to php5.ini too and tested another Snapshot.

    Still nothing.

    I really need to get this done.

    Please let me know . . .

    :slight_smile:

    P.S. Would just copying and pasting all the active plugins manually first (and activating all the plugins on the target site as there are on the donor site and activating the theme on the target site to and then doing the Snapshot restore from that point work perhaps or not)?

    P.S.S What are some workarounds etc if not . . . I need to push this site to the live root asap to get it going.

    NOTE: Of course, I would much rather just get Snapshot working on this subfolder WP install of the same server (as mentioned the Root WP install of this same server works perfectly). Please let me know something ASAP.

  • Greg

    Hey folks,

    I finally found the issue I think. There was a OLD.BAK plugin that had the permission of 0200 all alone even though the plugins folder itself had 0755 (as did all other plugin folders except that one old backed up plugin that was renamed in the past).

    So, I just ran the Snapshot again and the Plugin folder and plugins seem present.

    I have not tried to restore it to the other site yet ... but that is the update so far...

    :slight_smile: