What caused this blank screen across my entire installation and how do I fix it? error_log msg incl

What caused this blank screen across my entire installation and how do I fix it? error_log msg included:

[21-Jul-2012 21:14:25 UTC] PHP Fatal error: Call to a member function get() on a non-object in /home/domain/public_html/wp-includes/query.php on line 27

This is a new installation and was activating plugins network wide when this happened. I thought it was the custompress plugin that I added last, but even after deleting that folder from plugins, the problem still persists.

Ps. Once we can hopefully solve this without a fresh install, is there a list somewhere of conflicting or conflict free plugins mapped to each other?

  • xaviemirmon
    • Site Builder, Child of Zeus

    Hi @drivencompassion,

    Welcome to WPMU Dev. Without seeing your site or knowing what you have done recently I can't be certain what triggered this error. Generally, errors like this are caused by changing something in wordpress. Have you recently added any plugins, themes or done updates? If you haven't done anything recently then I would check in with your host. You might also ask your host about suppressing PHP errors to see if that helps. Hope that helps!

    Xavier

  • drivencompassion
    • The Incredible Code Injector

    Yes, I've been adding a bunch of plugins from wpmudev and was in the process of activating them. Are there conflicts between your plugins listed somewhere? Will I need to do another fresh install or do I have to delete all the plugins from the plugin folder?

  • drivencompassion
    • The Incredible Code Injector

    I thought it was the custompress plugin that I added last, but even after deleting that folder from plugins, the problem still persists.

    Do I need to remove all plugins? And even if I do that, how do I know what plugins conflict with each other? Is there a list of conflicts that's updated by the community when a conflict is found somewhere?

  • 3SixtyEvolve
    • New Recruit

    Hi @drivencompassion

    Thank you for your posts and glad to see that @xaviemirmon kept you company and tried to assist.

    Please confirm whether you installed via the WP Dashboard or via ftp. Also, have you installed our WPMU DEV Dashboard plugin?

    And lastly, please check to make sure that all the plugins that you've installed are Multiste compatible. If you install a plugin that is not compatible it could also cause this problem on your Multisite.

    Look forward to receive your feedback and assisting further.

    Have a good day!

    Gina

  • drivencompassion
    • The Incredible Code Injector

    Yes, I have WPMU Dev Dashboard installed, but how do I check if a plugin is MultiSite, multidomain, buddypress compatible or compatible with any other plugin for that matter? That's been my main question in this thread :slight_smile:

    Thank you @xaviemirmon and @Gina B for both of your help and time!

  • 3SixtyEvolve
    • New Recruit

    Hi @drivencompassion

    For WPMU DEV plugins you will find the compatibility mentioned on the sidebar. See my screenshot as example.

    However, for third party plugins you would have to check on their individual websites. Normally if you download from WP.org it would mention on the tags if it's compatible with Multisite, but for premium plugins you would have to get in contact with the authors.

    We also don't have a list of third party plugins that are compatible/ not compatible with our plugins. If you encounter plugin conflicts, the best way to handle it is to first deactivate all the plugins and then activate them one by one to see which plugin is the culprit.

    I hope this helps.

    And if you need any further assistance, please don't hesitate to be in touch.

    Have a good day!

    Gina

  • camparoo
    • Site Builder, Child of Zeus

    A bit more input from the peanut gallery: I recently had the same thing happen and I had to remove most of my plugins to get my dashboard back.

    I resolved this issue by making some changes to a few files. First, I added this to my wp-config file right before the salts:
    define(‘WP_MEMORY_LIMIT’, ’64M’);

    Then I added this to my .htaccess file
    php_value memory_limit 64M

    Then, I went to my php.ini file and upped the numbers here as well.

    upload_max_filesize = 64M
    post_max_size = 64M

    This saved my bacon.

    Also, just for posterity (and because I also wanted to upload larger files to some pages in my Network) I went to the Dashboard of my Network, logged in as Network Admin, and went to Network Settings. Near the bottom of this screen, you can change the file size that users are able to upload. Completely unrelated, but info you may need just the same, as non-networked sites are not constrained by this particular setting.

    Carry on!

  • Dean Kaus
    • The Bug Hunter

    Hello @camparoo Great advice! I've ran into this problem so many times, as I'd been adding plugins like crazy to test out what I like and don't like.

    The first time I had that issue I was able to fix as you mentioned in your above code. I did have one site (which was really weird as it was on the same server as my other sites) but whenever i installed Marketpress the page would go white, no error messages, couldn't get back to the dashboard nothing! i had to FTP in and manually delete the Marketpress folder before I could log back in. My hosting company was getting so frustrated as they couldn't figure out what was happening. So I told them to give me total control over my server (which they gladly did) After this happened I went into my virtulmin panel and to the php resources section and increased the allowed memory there and that solved all of my problems.

    i did run into another problem though as I set up a multi site and added a ton of themes, plugins etc... that in my dashboard I can't scroll down to see everything I have available. Well that problem is for another day but again wanted to thank you for your input.

  • camparoo
    • Site Builder, Child of Zeus

    Hi Dean,

    I just finished working with this adorable client who thought that there was no limit to the number of plugins you could use. How fuzzy-bunny cute is that? She wanted me to add Markepress to her site with 32 active plugins and could not understand why I was less than thrilled! Etch.

  • Dean Kaus
    • The Bug Hunter

    @canparoo I'm kinda like that but and old gray fuzzy bear! Not so cut to top that off LOL.
    I felt just like here where I wanted to try them all, sometimes I just feel like a kid in a candy store! I just love them all.

    Have a great one. Better get some zzzz's myself have church in a few hours.

  • drivencompassion
    • The Incredible Code Injector

    Oh, so we can't see that compatibility from within our domain's WPMU Dev Plugin.

    1. I would be willing to provide anonymous feedback of synergistic plugins vs conflicting plugins through my install. Does anyone else feel that if we provided this anonymous feedback, WPMU Dev plugin authors would have better information regarding these conflicts to improve compatibility across a higher range of plugins than what is currently available?

    2. For example, it would be nice to see a drop down of what plugins are running across other installations that are showing synergy or if it's easier to display, conflicting with https://premium.wpmudev.org/project/multi-domains/

    3. How do we deactivate plugins as recommended when we get the white screen problem, if we don't have access on any page? The only way I know of is to go into the plugin folder via FTP and delete plugin folders completely. Doesn't this also delete configuration details, if we later find that one of the plugin folders we deleted while trying to find the conflicting plugin needs to be restored?

  • drivencompassion
    • The Incredible Code Injector

    4. Thank you for your recommendation above camparoo: php_value memory_limit 64M

    When I update this via http://wordpress.org/extend/plugins/bulletproof-security/ by editing the custom page, I got a 500 Internal Server Error. Before I updated the custom value, it was working. Deleting the .htaccess file, brings the site back. All the other updates you suggested were made as well, but is the htaccess custom code correct?

  • 3SixtyEvolve
    • New Recruit

    Hi @drivencompassion

    In response to your latest post, here are my answers :slight_smile:

    1) Providing anonymous feedback would be a great feature. Not sure how it can be implemented, but I will send a note to the Lead Developer to get his feedback on this.

    2) A drop down of what plugins works well/ doesn't work well would also be a great addition. I will also add this to the note to the Lead Developer.

    3) Actually, I always create a copy of my wp-contents/plugins folder when something like this happens and then delete from the current plugins folder and once I know the culprit plugin I reinstate the copied version of the plugins folder, minus the culprit plugin. Note that even if you delete a plugin, if you had any specific settings, pages or posts created via those plugins it would remain on the database. I've deleted plugins and when I later installed it again I had the same test content as before. Hence why we always advice people to upgrade the larger plugins by deleting the old copy and installing a fresh latest version. Deleting the plugin won't remove the settings :slight_smile:

    Please don't hesitate to be in touch should you need any further assistance.

    Have a great day!

    Gina

  • drivencompassion
    • The Incredible Code Injector

    Thank you Gina for passing on the suggestions. FYI: Buddypress 1.6 is not compatible with many WPMU Dev plugins

    Not sure why I can't update my htaccess as stated in my question #4 above, but until I get some insight on that end will continue testing various plugin combinations.

  • Dean Kaus
    • The Bug Hunter

    Hello @drivencompassion and @Gina B
    What I'd suggest before messing around with the htaccess or other files you may want to contact your hosting company if you don't have control over your servers PHP resources. I had spent days trying to figure out which plugin was causing the problem especially when it came to marketpress. I deleted plugins re-installed them in a different order etc... Then I had messed up my system and files so much and couldn't remember what was what, I uninstalled everything, had my hosting company clear out any old files and make sure I had a fresh start and re-installed everything from scratch. As soon as I got back to the point to install Marketpress and only using known plugins that worked on my other sites without incident, then the white screen of death once again shut me down.

    Here is what I did and it solved my problem without having to delete ANY folders or plugins or re-install the site or anything else. I got into my servers php.ini (i believe that's the correct file) I selected it from a control panel. Some hosting companies may have to do this for you depending on your hosting company.

    I've attached screen shots to show what I did. Please try this and let me know if it works out for you. If all of my wasted hours trying to find a solution can save someone else all of the time and headache then that will be great!

  • drivencompassion
    • The Incredible Code Injector

    I previously updated my php.ini to 256MB, so the only other place I need to update this, if that is in fact something I need to do is in the htaccess file. Thanks :slight_smile:

    If we can get a resource of anonymous data to analyze plugin and plugin version compatibility both w/in WPMU Dev as well as popular external plugins, that would be great!

  • Dean Kaus
    • The Bug Hunter

    sorry everybody, I may not have explained properly. I had edited the php.ini file however the hosting company had a limit of 64m set. So reguardless of what I had it set for I was only getting 64m. After getting in touch with my hosting company to get this limit removed and let my settings actually take precedence then everything started working.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.