What goes in this empty space?

Wp 3.3.1 when a subscriber is logged in there is a big blank box. How can I fix this or put something in it?

  • aecnu
    • WP Unicorn

    Greetings Atlanta,

    Wp 3.3.1 when a subscriber is logged in there is a big blank box. How can I fix this or put something in it?

    Thank you for this great question and a significant issue to bring up.

    I have tested this out in our development environment and confirm the issue and I am now going to discuss it with the lead developer - to get a fix sorted for you asap.

    Cheers, Joe :slight_smile:

  • Vladislav
    • Dead Eye Dev

    Hello,

    This is the space that is usually populated with dashboard widgets - some of them come with WordPress, and there are many plugins that add their own dashboard widgets as well.

    Using Easy Blogging plugin (https://premium.wpmudev.org/project/easy-blogging), you can create your own content that will appear in that area when your users initiate Easy mode. To do so, you can go to your Easy Blogging plugin settings and set "Show dashboard widget" option to "Yes". In the fields below you can then add your widget a title and any contents you'd like.

    You can do a similar thing in your regular admin dashboard using the Custom Dashboard Widget plugin (https://premium.wpmudev.org/project/custom-content-dashboard-widget).

  • Atlanta
    • Syntax Hero

    Thanks. The custom dashboard widget doesn't fill the checkered box in the image. It fills a box next to it.

    I tried easy blogging a couple of months ago and deleted it because it didn't have an option for Marketpress custom posts. Has that changed? The plugin description doesn't say. And will the easy blogging fill in that blank checkered box?

    Thanks again.

  • aecnu
    • WP Unicorn

    Greetings Atlanta,

    Thanks. The custom dashboard widget doesn't fill the checkered box in the image. It fills a box next to it.

    In my test environment I was able to drag the dashboard widget I created over to the dotted line box and the box disappeared being replaced by my dashboard widget.

    I may have a solution for you - have you tried the Custom Widget Order plugin?

    That may definitely do the job for you - I would love to hear how it goes if you try it out?

    Please let us know if this does not resolve your problem by reopening this ticket below marking it as not resolved. Also please indicate if there are any new symptoms or errors.

    Cheers, Joe :slight_smile:

  • Atlanta
    • Syntax Hero

    Thanks. The custom dashboard widget doesn't fill the checkered box in the image. It fills a box next to it.
    In my test environment I was able to drag the dashboard widget I created over to the dotted line box and the box disappeared being replaced by my dashboard widget.

    Interesting, I tried dragging the dashboard widget over and it just switched places with the checkered box. The checkered box did not disappear. Firefox and Opera browsers.

  • Tanmay
    • Flash Drive

    Greetings @Atlanta,

    Activate Easy Blogging and then activate Manage menu items add-on for Easy Blogging.

    Add URL for menu items you want to display and check Show box. Good to go.

    And yes it will fill blank checked box. I tested it.

    Keep us updated about further development on this issue.

    Take Care.

  • aecnu
    • WP Unicorn

    Greetings Atlanta,

    I suppose this is due to Show "Right Now" in Dashboard selection is turned off leaving the open space which in turn leaves the dashboard attempting to fill itself rendering the dotted line box.

    In conclusion, there must be two widgets (one each side left and right) of some kind in the Easy Admin Dashboard for the dotted line not to show.

    Thank you for being a WPMU Dev member!

    If we can be of further assistance please let us know.

    Cheers, Joe :slight_smile:

  • Atlanta
    • Syntax Hero

    I suppose this is due to Show "Right Now" in Dashboard selection is turned off leaving the open space which in turn leaves the dashboard attempting to fill itself rendering the dotted line box.
    I don't see a show right now and where is dashboard selection?

    I was able to change the number of columns to 1 in screen options>screen layout which then placed the widget inside the box, but how would I make that a default display for a subscriber to see?

  • Tanmay
    • Flash Drive

    Greetings @Atlanta,

    I worked it out. Here is the code that will help you to force Number of Columns to 1 in Screen Layout option.

    function customize_dashboard() {
         global $current_user;
         get_currentuserinfo();
         //if current user level is less than 1(User Level 0 converts to Subscriber), change Number of columns to 1
         if ($current_user->user_level < 1)
              change_screen_layout_dashboard();
    }
    add_action('admin_init','customize_dashboard');
    
    function change_screen_layout_columns( $columns ) {
        $columns['dashboard'] = 1;
        return $columns;
    }
    add_filter( 'screen_layout_columns', 'change_screen_layout_columns' );
    
    function change_screen_layout_dashboard() {
        return 1;
    }
    add_filter( 'get_user_option_screen_layout_dashboard', 'change_screen_layout_dashboard' );

    Add this code to functions.php. Hope this helps.

    Try it out and let me know.

    Have a nice day. :slight_smile:

  • Tanmay
    • Flash Drive

    hiya @Atlanta,

    Sorry, code in previous post will force 1 column for all users. Wrong control flow. :slight_smile:

    Here is edited working code:

    function customize_dashboard() {
         global $current_user;
         get_currentuserinfo();
    
         //if current user level is less than 1(User Level 0 converts to Subscriber), change Number of columns to 1
         if ($current_user->user_level < 1){
              add_filter( 'get_user_option_screen_layout_dashboard', 'change_screen_layout_dashboard' );
    	  add_filter( 'screen_layout_columns', 'change_screen_layout_columns' );
         }
    }
    add_action('admin_init','customize_dashboard');
    
    function change_screen_layout_columns( $columns ) {
        $columns['dashboard'] = 1;
        return $columns;
    }
    
    function change_screen_layout_dashboard() {
        return 1;
    }

    This will do. I tested on my installation.

    Take care.

  • aecnu
    • WP Unicorn

    Greetings Atlanta,

    I don't see a show right now and where is dashboard selection?

    Go to network admin dashboard -->Easy Blogging-->Show "Right Now" in Dashboard is located bottom of page directly above "Save Changes"

    I was able to change the number of columns to 1 in screen options>screen layout which then placed the widget inside the box, but how would I make that a default display for a subscriber to see?

    Thanks for bringing this up, New Blog Templates plugin could definitely do the job for you - I would love to hear how it goes if you try it out?

    Cheers, Joe :slight_smile:

  • aecnu
    • WP Unicorn

    Greetings Atlanta,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

  • Atlanta
    • Syntax Hero

    @tanmay
    I pasted

    <?php
    function customize_dashboard() {
    global $current_user;
    get_currentuserinfo();

    //if current user level is less than 1(User Level 0 converts to Subscriber), change Number of columns to 1
    if ($current_user->user_level < 1){
    add_filter( 'get_user_option_screen_layout_dashboard', 'change_screen_layout_dashboard' );
    add_filter( 'screen_layout_columns', 'change_screen_layout_columns' );
    }
    }
    add_action('admin_init','customize_dashboard');

    function change_screen_layout_columns( $columns ) {
    $columns['dashboard'] = 1;
    return $columns;
    }

    function change_screen_layout_dashboard() {
    return 1;
    }
    ?>

    In functions.php and it blanked out my site.
    I placed it at the end of the funcitons.php file.

    @aecnu New blog template does not carry the number of columns of one over to the next site. The new site starts with 2 dashboard widgets.

    Any other suggestions?

  • Atlanta
    • Syntax Hero

    Hello, I am still trying to get rid of the blank box in the admin panel.

    I tried easy blogging with custom dashboard widget. I network activated the custom dashboard widget and entered content but it does not display any content in the blank box neither does it get rid of the blank box.
    I tried to site activate custom dashboard widget on my template but there was no option to site activate it with or without network activation.

    I tried the suggestion of using just one column in the screen options but it does not carry over from the template to the next site created.

    I tried the option of pasting text in domain.com/wp-includes/functions.php but it made the whole site disappear.

    Any other suggestions?

  • aecnu
    • WP Unicorn

    Greetings Atlanta,

    Thank you for lett us know and I have made it a permanent part of this ticket so that other members may benefit.

    <?php
    function customize_dashboard() {
    
              add_filter( 'get_user_option_screen_layout_dashboard', 'change_screen_layout_dashboard' );
    	  add_filter( 'screen_layout_columns', 'change_screen_layout_columns' );
         }
    
    add_action('admin_init','customize_dashboard');
    
    function change_screen_layout_columns( $columns ) {
        $columns['dashboard'] = 1;
        return $columns;
    }
    
    function change_screen_layout_dashboard() {
        return 1;
    }
    ?>

    Cheers, Joe

  • Atlanta
    • Syntax Hero

    This code worked for the admin role only, not for other roles. It actually blanked out the site for other roles. In wpmu chat I was told that this is the reason why

    "The hide personal options() function is doing the hiding but it’s doing it by hiding varous pieces of the form. Since the layout changes depending on your role, the pieces change. His code ha things like table:first which would hide the first table in the form. That kind of impllies there are more than one table for the admin and maybe only on for subscriber. So when it hides the first one for subscriber thats the whole thing. You’d need to look at the structure of each case to see what changes."

    How do I fix?
    I am looking for code to use in mu for both this ticket and https://premium.wpmudev.org/forums/topic/how-do-i-remove-this-part-of-the-profile-screen-from-the-dashboard?replies=16#post-209628

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.