What is going on with E-Newsletter?

Ok this happened again. Not sure why but E-newsletter 2.3 was working perfectly fine and then again when I have an newsletter that had to be delivered I get an error cannot connect to smtp server. i didn't change any settings and used the same computer etc... I've been ill so haven't been on here lately. In fact cole was unable to figure out last time. I installed an older version and that took care of the issue. Now not only does the older version not work. I accidentally upgraded to the newer version (really didn't want to do this) by selecting to upgrade all of the WPMU stuff from the dashboard. Now my custom themes are gone as well as the new version doesn't even show all of the templates that came with the plugin!

New layout is totally confusing and now I know why a couple of my clients went back to godaddy and their easy page designer...

  • Dean Kaus

    Sorry not to respond sooner. On the road and still trying to get things working for my clients. At any rate I don't have another smtp plugin and using the settings within the e-newsletter. I had the version numbers wrong. I'm now (as I inadvertently upgraded to latest 2.1.1) on version 2.1.1 thinking that upgrading it would solve the problem as in a notice I received via email had said that the email issues had been solved as well as many new improvements. These improvements didn't work and further more I lost my customized themes.

    Saw in some of my older notes that I had re-installed version 1.2.5 and that version was working fine until the other night.

    I don't know if my servers allow me to set up smtp or php emails or not.

    Going a little crazy here. Any and all help is appreciated. I ended up having to set up a mailchimp account to get these newsletters out. Confusing for clients because the template isn't the same and had the mailchimp logo and advertising on it. Had 6 cancellations already.

  • Dean Kaus

    @Maniu and possibly @pc. Wondering why I still don't have an answer to my problem.
    To reiterate.
    I had 2 different websites using e-newsletter and both were working fine. Then for no apparent reason I received the error:cannot connect to smtp server.

    I was using the gmail settings and had not changed them. @maniu we had discussed earlier when one of my sites quite working after I had upgraded to a newer version of e-newsletter. You had me reinstall the old version which then worked.

    This time when the e-newsletter quite working In a panic I did upgrade to the latest version of the e-newsleter. One of the websites had worked in the past with the newer version but no neither work at all. I checked as much as I could and the only things I can think is that gmail changes something to make it not work.

    I can't believe that I'm the only person having this problem. Not unless something changed something on the servers. I did mention to Joe and even tried to set up my own SMTP on my server with little luck.

  • PC

    Hey Dean,

    Thanks for your post and sorry for the delay in response. With the Team meetup at NYC, the response times have increased.

    There have been a lot of mods in the new version including how emails are handled. Can you please advise which version you are running ?

    Here is the change log of version 2.2

    * Added ability to export members
    * Added ability to search and easily filter members by: bounced, unsubscribed, ungrouped
    * Added ability to edit members details
    * Improved bounce test
    - Improved members sorting
    - Improved preview email to make it as close to proper email as possible
    - Fixed duplicating already subscribed members when WP user registers
    - Fixed incorrect URLs for sites with different home url then site url
    - Other small improvements

    Can you please upgrade to the latest version and see if that helps ?

    Please advise.

    Cheers
    PC
    Sales &Support

  • Dean Kaus

    hello @pc Not sure which site you looked at as I have a few test sites and then client sites. I have the latest version of the plugin on the wsrg.biz site and that is one of the sites in which I need the newsletters to go out on a regular basis. We've since switched over to the free mailchimp account as that seems to always be working.

    On another note regardless of which site or which version of e-newsletter I've installed, all of the sites using e-newsletter give me the same error message. So I think that something has to have changed from the communication of the plugin and gmail smtp server.

    I read on another forum (but didn't find a solution) that if the error message contains mail() and not wp-mail or something else to that effect that a php file needed to be edited. I tried to go back and find that post but with all of the storms and flooding here I've been losing internet so often...

  • PC

    Hello Dean,

    Thanks for posting back.

    Not sure which site you looked at as I have a few test sites and then client sites. I have the latest version of the plugin on the wsrg.biz site and that is one of the sites in which I need the newsletters to go out on a regular basis.

    that is the site on which I see e-Newsletter Version: 2.1.2 installed.

    On another note regardless of which site or which version of e-newsletter I've installed, all of the sites using e-newsletter give me the same error message. So I think that something has to have changed from the communication of the plugin and gmail smtp server.

    I read on another forum (but didn't find a solution) that if the error message contains mail() and not wp-mail or something else to that effect that a php file needed to be edited. I tried to go back and find that post but with all of the storms and flooding here I've been losing internet so often...

    Can you please post me a screenshot of the error and your email settings in the plugin ? I will then try to test it with the same settings and see if I can replicate it and if required call in our lead developer !

    Cheers
    PC
    Sales &Support

  • Dean Kaus

    Hello @pc and @Maniu I use @aecnu (Joe which I haven't seen on here in a while) not sure if he changed his name on here as it doesn't pop up when I start typing his name)

    At any rate I'll try to send him an email and see but I thought that those ports were open.

    If I can't get in touch with Joe is there a way I can test to see?

    I also noticed that on one of my other sites (same server) I haven't been receiving my email that are normally forwarded to my gmail account. The mail not delivered message said something about not being delivered due to significant abuse from the ip address.

  • TiffanyL

    Hey ya guys,

    Chiming in here to let you know that I too encountered error with hosting server being used (As per their instructions for standard SMTP setup non SSL on port 26 - the hosting co.'s recommendation.)

    Kept receiving same error re SMTP though each time I would check the settings click Test and all good. Test message received.

    Go back to Newsletter to send Preview Newsletter to an email address - no go! SMTP error as per @PC described above only mine said something like Error Check Outgoing SMTP Settings.

    So I did, and then tried switching to the hosts recommended settings for SSL instead on Port 465 - Test sent and all good, saved.

    Back to newsletter - send Preview email - and it was all good! Went through no errors like a charm.

    I know this information may not help the case but it lets you guys know there is an issue there somewhere, at times, even if Testing SMTP is all good...

    Either way mine works now using host settings for SSL, but not for non-SSL settings on port 26.

    (Added note std settings on non-SSL work fine with Outlook 2010 so is not port 26 being open/closed as I know it's open via this comparative test).

    Hope the notes can help you guys figure it out though as I will be using it on other client systems. :slight_smile:

    Have a terrific day.

    Tiff.