What is going on with the versions of Membership 2 Pro?

What is going on with https://premium.wpmudev.org/project/membership/?

The web page shows that 1.0.2.7 is the latest version, but then I've been using it for 4 weeks and this week it told me that 4.0.0.7 was the latest version.

So I updated the plugin, and now it tells me that I'm not using the PRO version: http://www.awesomescreenshot.com/image/1055706/99c240e54eeb2d210a6574f99a75b91a

WHAT IS GOING ON?

Why would your system tell me to upgrade when 1.0.2.7 is the latest version? And can I revert back to the old version or is all my data now transferred into the new version (it made me do some sort of import after I upgraded).

I CANNOT RUN MY BUSINESS WITH MISINFORMATION ISSUES LIKE THIS HAPPENING.

Which version is the latest version?

How can I get my system working properly with the latest version?

I need a response back ASAP as I have some outstanding coupons that users are expecting to be able to use and I'm going to lose revenue if they can't use them.

Thank you for your prompt support.

  • Predrag Dubajic
    • Support

    Hi Michael,

    Apologies for the long overdue on this thread, for some strange reason the thread was not showing in our feed, we have notified system admins to check what's going on and why it happened for your thread.

    Version 4.0.0.2 is free version available from wp.org repository but update notification shouldn't show if the plugin is active or if you have WPMU DEV Dashboard installed.
    Can you please try clearing your browser cache and data from caching plugins, if you have any, and see if the update notification is then still showing even when M2 is active?

    Why would your system tell me to upgrade when 1.0.2.7 is the latest version? And can I revert back to the old version or is all my data now transferred into the new version (it made me do some sort of import after I upgraded).

    Which version was initially installed on this site?
    Import should show up only when updating from Membership Premium (Membership 1) to Membership 2 Pro, but this switch was made way back in June so I doubt that you had Membership Premium when this update happened.

    If you had 1.0.2.7 before the update to 4.0.0.2 was performed then you should be able to switch back to Pro version without any issues.

    Do you have backup of your site before this happened so you can restore to that?

    Best regards,
    Predrag

  • MC
    • Site Builder, Child of Zeus

    Hi Predrag,

    I saved a copy of the version 1.0.2.7 (PRO) plugin and was able to revert from version 4.0.0.2 (free) to 1.0.2.7 (paid, PRO) without issue. It's always scary when you do an update and something gets screwed up when it's not your fault (which most of the time, it is!), so my apology for my tone in the initial post. :slight_smile:

    I'm still experiencing the same issue:
    https://dl.dropboxusercontent.com/u/3986495/WordPress-Updates-20160310.png

    You can see that I'm running Membership 2 Pro, version 1.0.2.7 and that it's asking me to update to Membership 1, version 4.0.0.7.

    Why would it even ask my to upgrade to 4.0.0.7 if it's not the same plugin (this version is not the PRO plugin).

    Just to reiterate, my site has been reverted to the fully-functional PRO plugin and all is good. But it's still asking me to upgrade, and I'd like to have it stop asking me to upgrade to a lesser version of a different plugin.

    Thanks for your support,
    Michael

  • Predrag Dubajic
    • Support

    Hi Michael,

    I understand your frustration, no need to apologize, I'm glad to hear that reverting back restored everything in previous state.

    As for the update notification, it's strange that it's still showing for you since the plugin has rule in code to not check wp.org for upates, this of course requires plugin to be active, which is in your case, so I'm a bit baffled here.

    Would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Predrag

  • MC
    • Site Builder, Child of Zeus

    Hi Predrag,

    I used to have the WPMU Dev Dashboard plugin installed on my DNAcademy.com website, but it was causing 504 errors (my developer narrowed the issue down by viewing these tickets: https://premium.wpmudev.org/forums/topic/latest-version-of-dashboard-causing-502-error & https://premium.wpmudev.org/forums/topic/wpmudev-dashboard-crashed-my-install).

    I operate this website as a business and cannot afford more downtime, so I do not want to install this plugin again. Is there another way to provide you access so you can view the issue?

    Thanks,
    Michael

  • Predrag Dubajic
    • Support

    Hi Michael,

    There were two updates for WPMU DEV plugin since those two threads, did you try running 4.0.8 (current latest version) to see if the issue is still happening after that?

    You can also send us your details using our contact form https://premium.wpmudev.org/contact/ and the template below:

    IMPORTANT: Make sure you select "I have a different question" for your topic so it doesn't go back to forums - this and the subject line ensure that it gets assigned to me.

    Subject: "Attn: Predrag Dubajic"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - Link back to this thread for reference
    - Any other relevant urls

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.