What's with the hashtag being added to product page URLs?

For some reason, after I publish a product page, a hashtag (# sign) is being added to the URLs.

Why is this and what can I do about it?

  • aecnu

    Greetings dawsonbarber,

    The hash tag is a complete unknown to me for this product as you can see in my production test site, it does not exist anywhere in any URL's.

    Therefore I suspect something is going on there and adding it but I do not know if it is a plugin or theme.

    So I shall start from the top.

    Are you running WordPress 3.3.1?
    MultiSite or Solo?
    Buddy press?
    Theme name?

    You may want to quickly and temporarily check if the hash signs exist with the Twenty Eleven theme before troubleshooting the plugins.

    Have you attempted standard troubleshooting technique of deactivating all other plugins except Market press in this case and check for the anomaly hash sign? and then if it is not present when creating a post with all other plugins deactivated is the hash sign still present.

    If not then re-activate each plugin one or two at a time to hunt down which plugin may be causing this?

    Please advise.

    Cheers, Joe :slight_smile:

  • dawsonbarber

    Hi there

    I didn't catch this response in time, so I ended up deleting the entire installation and starting all over again.

    The problem didn't come back with the re installation. And I haven't reinstalled all of the same plugins, so I'm guessing it must have been a plugin.

    Sorry that I didn't catch this in time to have gone through the plugin-elimination process - and I really don't know which plugins were installed on that site (started setting it up a few months ago) - but if the problem returns, I'll definitely ferret out the cause and report back.

    Thanks

    Dawson

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.