When activating the plugin while using Multi-DB I get

When activating the plugin while using Multi-DB I get the following error from the Shopp plugin:

"Sorry! Shopp cannot be activated for this WordPress install.

Shopp cannot be installed because the database privileges do not allow Shopp to create new tables."

Any idea as to why Multi-DB would be blocking a plugin from creating a new database table?