When an appointment is created, the service provider is not notified via email. Only the client.

What am I missing? The log shows the email being sent to the client.

Also, I checked the other discussions about GCal syncing. I don't care if the client's calendar gets synced. I wanted the service provider to get it on his GCal. I bought this plugin mainly for that reason.

I found a thread with a similar question (https://premium.wpmudev.org/forums/topic/appointments-emails) and I have my settings just like that guys says. Still, the service provider get nothing.

Thanks for the help!

  • aecnu
    • WP Unicorn

    Greetings coes1,

    Welcome to WPMU Dev!

    Sorry to see that you are having issues with the Appointments+ plugin.

    Regarding GCal syncing I cannot find out anything about it with the exception of this on the home page of the plugin: Manage all appointments right from Google calendar

    I could not see how this was/is done so I must indeed be somehow missing it too.

    Therefore I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • Hakan
    • The Incredible Smush

    Hi,

    The log only records user email because admin and service provider are always bcc'ed, provided that there is one (In no preference case obviously confirmation is not sent to the provider, because there is none). You cannot even turn this property off.

    I just checked this maybe 100th time again and I, as service provider, got the bcc copy of the confirmation email.

    Did you check your spam folder and are you sure that no preference is not selected?

    Regarding GCal, service provider can submit appointments to his GCal calendar using GCal buttons on his user profile page. There is no automatic GCal sync yet.

    Cheers,
    Hakan

  • coes1
    • New Recruit

    Hi!

    Thanks for the replies.

    I must be missing something. I have one user (who is the admin) and this user is definer as service provider of the one service I have activated now.

    When I go to profile page (left toolbar>user) I see the regular email address for profile and also the My email for A+ field. I fill out both fields with the same email address.

    In the Settings page of A+, I have 'Send Confirmation Email' as yes, 'Send Notificatoin to Admin if Confirmation is required' as no. I have no payment required and Auto-Confirm as yes.

    I create an appointment, user receives confirmation but service provider/admin does not. I have checked spam too.

    I am sure the script works like you say but there's some setting that is not too intuitive that I'm missing.

    Thanks.

  • coes1
    • New Recruit

    Oh and also, in the Make an Appointment page, in the Service Provider selector I am choosing a provider. Meaning, the option No Preference is NOT selected.

    I also just created a new user to see if that was the problem and I get nothing.

  • coes1
    • New Recruit

    Also, I don't see the GCal buttons in the profile page (assuming I'm using the WP profile page option). All I see is profile info, then the A+ section (which is more contact info) and then the appointments status. No GCal button,

  • Hakan
    • The Incredible Smush

    Hi Israel,

    I included myself as a service provider ( ***@hotmail.com) and made an appointment from the front end using another email account (***@gmail.com).

    I DID received a confirmation email as service provider (to ***@hotmail.com).

    I think you need to check if you get any emails as bcc to your service provider email hello@simple***design.com. I regret to tell you that we cannot check this for you.

    Just a notice: I see logs like this:
    [November 16, 2012 3:41 pm] Confirmation message sent to hello@simple***design.com for appointment ID:5

    This is already your service provider email. Try to use different email accounts for client and provider while testing.

    Regarding GCal, you didn't select "Add Google Calendar Button" as Yes. I changed it and now GCal button is visible.

    Cheers,
    Hakan

  • coes1
    • New Recruit

    Hi Hakan!

    Thank you for your help and for stepping up and checking what the problem was for yourself.

    This conclusion definitely should bring insight into anyone having a similar issue in the future.

    I appreciate it.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.