When attempting to purchase download no link to download given

I have attempted to post a downloadable product (pdf) which is an option made available. I have uploaded the product, made the product free, can see the product, add it to my cart, can click buy, and am taken to the thank you page with a link to check the status of my order.
Under the purchase description there is no option to download and no email sent to offer a link to download.
I'm sure it's something simple but what might have I done that is so wrong? I have a screen shot if it helps.

Thanks

Here's a screen shot.

  • ianM

    Hi Timothy.
    Success!

    Thanks for getting back to me. Sorry about the screen shot, but I wasn't sure which area are you would like me to shoot a picture of.

    You entered a question mark in your reply to me, which I assume you meant as to ask that I be sure that I do have a product available to download.

    I went looking about and found an interesting thing in the media section. There was my file, but the file was not Attached to anything; product, post or page, and I suppose that is incorrect. I was not able to attach it to anything.

    I deleted the media and tried to upload it again through products, but it just hung there after reaching 100%. I'm sure that's what happened before and I just assumed that it was done doing what ever it had to do.

    Clearly I hadn't waited long enough for it to complete the first time, and now I am realizing there is probably a problem with uploads, as this is my first attempt to upload a product through the browser.

    I got tired of waiting.

    So I noticed there were three options to upload. From my computer by drag and drop, enter a URL, or choose from the media library. While it was hung at 100%, I switched my choice method it then began "crunching" and appeared in the media library section of the upload options page - I found the file and filled in the info and selected the "insert into post" button.

    I was taken back to the product creation page and I hit "update".
    I logged out and attempted to download it again. It worked. And, this time it only asked for my email address before moving on. No shipping info requested.

    This first bit was for anyone else coming along after me with the same problem.

    But now I realize the problem is probably with uploading. Is that a bug? Because I was able to make it work by pushing a different button it seems to be a bug with the plugin.

    Would it be helpful to suggest that perhaps this problem is due to the upload page being able to accept more than one product upload at a time? Perhaps it didn't begin crunching until I tried to move away - effectively informing it that I was done uploading. Perhaps new buttons could be added to this product uploads page that says - Done, or Cancel - or something else.

    I appreciate your help with this. Let me know if I should start a new thread for the upload problem for my site, as I expect this feature to be very important to my goals.

    Thanks again.

  • Timothy Bowers

    You entered a question mark in your reply to me, which I assume you meant as to ask that I be sure that I do have a product available to download.

    :slight_smile:

    I deleted the media and tried to upload it again through products, but it just hung there after reaching 100%. I'm sure that's what happened before and I just assumed that it was done doing what ever it had to do.

    Could be a memory issue, could just be a timeout or a dropped connection.

    Just read all your post then realised you said it was resolved at the bottom :slight_smile:

    Glad it's all sorted now. If you have any other uploading issues then please let us know.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.