When enter web site adress, being redirected to/wp-signup.php?new=sitename.com

Hi there,

I have problem on my site. When I am enter site address to my browser I am being redirected to http://www.theblogger.com.au/wp-signup.php?new=theblogger.com.au
I have found code line on wp-signup.pho
" if ( !is_multisite() ) {
wp_redirect( site_url('wp-login.php?action=register') );
die();
}"

Maybe the problem is in this line ?
My web site is http://www.theblogger.com.au
Any suggestion ?
Thanks in advance!

  • faufau
    • Flash Drive

    Hi David,
    Thanks for fast respond.
    I am using firefox and safari, and I see it on both browsers before.
    Now I just find primary solution for it on one of wordpress web site.

    Connect to phpMyAdmin and you'll find a table named wp_blogs (or any other prefix you choose).
    If you've got the redirect problem, in the field domain, normally you'll find the value http://www.yourdomain.com (without http:// wordpress.org transform my code...) replace it by yourdomain.com

  • Mason
    • DEV MAN’s Sidekick

    Hiya faufau,

    This is the default behavior for WordPress multisite when you are already logged in and have site registrations enabled.

    A visitor will be asked to create a username (and then a site if they wish) a logged-in user goes straight to the new site step.

    Hope that clears it up for ya. Thanks!

  • faufau
    • Flash Drive

    Hi masonjames,
    I know that is default behavior of WPMU. But if this problem appears, it can be solved.
    As I posted before when I do changes on wp_blogs database this default thing do not appear(but after I can not access network admin panel in usual way), so that means there is solution for it...
    Cause I dont want to have user registration steps u have mentioned and it not makes me clear.

    I think this problem must be solved years ago before u started this business...
    Hope to get clear advices on my prob.

  • faufau
    • Flash Drive

    Solution is in bold line!

    define('WP_ALLOW_MULTISITE', true);

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.domain.com' );
    define( 'NOBLOGREDIRECT', 'http://www.domain.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    Looks like users from each other here can find more help than from u guys...

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.