When entering an appointment, lasting 30minutes at 4pm

When entering an appointment, lasting 30minutes at 4pm on the 11th of July, i find that the times from 2.45pm-4pm were then marked unavailable. Why is this? I want it to just mark out the 4pm-4.30pm time.

http://borders-lbs-and-ozs.co.uk/wp/?page_id=10&wcalendar=1372636800&app_service_id=1

  • Hillside
    • Flash Drive

    Hi Ari,

    Sorry, i realised the issue after posting my question. I was choosing a service which needed that much time ahead of an appointment, hence the blocked times.

    I do have another query. If i want to block out part of a day, if the clients i out of office from then, for example from 3.30pm onwards on a specific date rather than setting a whole day in exceptions how would i do this? (The longest service lasts 90mins so i can't used this to block it out)

  • aristath
    • Recruit

    No, I'm afraid that breaks are not date-specific.
    What you can do is specify an exception for the whole day though by going to the exceptions tab!

    Otherwise you can simply edit the break dates then and when that dats passes then edit them back to their normal status.
    Not ideal, I know.
    But it's the only way to do it at this point.

    Cheers,
    Ari.

  • pxwm
    • WP Core Meltdown

    Hi @ari - Hope you don't mind me making a suggestion

    Hi @hayley

    You could consider creating a personal google calendar through a google account or if you already have one then use this.
    Then in A+ setup the 'Google Calendar (GCAL) tab so it is integrated and is set to fully synchronised between A+ and your google calendar in both direction.
    There is a comprehensive set of instructions in the A+ 'Google Calendar' tab if you click on the 'i' icon.

    You could then block out specific dates and times through your google calendar.

    Hope this helps
    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Hillside

    Could you please try the following:-

    Loggin to your Wordpress dashboard using Admin
    Select A+ settings
    Select the 'Google Calendar' tab
    Then scroll to the bottom and click 'test connection'

    Do you receive a success message at the top?

    Could you please screenpost all your settings in the 'Google calendar' tab

    Regards
    SteveB

  • Hillside
    • Flash Drive

    Hi,

    This hasn't helped. When i clicked update the calendars i saw 3 appointments added to the google calendar, these weren't accurate with what is in the APP+ calendar. See attached images. Only this day was affected and you can see there are multiple dates with appointments.

    Not sure what is going on or to do.

    Hayley

  • pxwm
    • WP Core Meltdown

    Hi @Hillside

    With the 'Allow Service Providers for Google Calendar API Integration' field set to 'No' could you please try:-

    Loggin to your Wordpress dashboard using Admin
    Select A+ settings
    Select the 'Google Calendar' tab
    Then scroll to the bottom and click 'test connection'

    Do you receive a success message at the top?

    If you receive a success message could you screenpost the timezone settings in Wordpress and your Google calendar.

    Also could you provide one example of the incorrect times.
    e.g. could you confirm the appointment time showing in A+ and what it displays in your google calendar as it is difficult to match up from the screenposts.
    Assuming the dates are okay and it just a time shift could you please confirm the difference in the time shift between A+ and your google calendar.

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.