When I activated this plugin, getting `Strict Standards:

When I activated this plugin, getting
Strict Standards: Static function Popover_Rules_Rule::add() should not be abstract in F:\my\local\path\wp-content\plugins\popover\popoverincludes\includes\functions.php on line 447
message.

and,at the pop-up's page, getting

Warning: Illegal string offset 'popover_check' in F:\my\local\path\wp-content\plugins\popover\popoverincludes\classes\popoveradmin.php on line 854 in the conditions field.

I'm using WordPress 3.7.1 and php version 5.4.19

Just wanted to let you know!

  • Ash

    Hello there

    I hope you are well today and thanks for asking the question.

    About the strict message, this message is not harmful for your project. Actually you are using updated version of php. But the plugins are designed in the way so that it can run on older versions of php too. So, when it sees codes for older versions, it shows a message. So, you can ignore it.

    About the warning, change the line 854 with the following:
    $rules = isset($p['popover_check']) ? $p['popover_check'] : '';

    Please let me know if it is helpful and feel free to ask more question if you have.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.