When I click on 'Map Domain' nothing happens

Everything is set up as it should
dedicated IP: YES
dedicated IP opens website
sunrise.php moved to wp-content folder
'A' record of domain set to IP address of multisite.
wp-config is setup properly
Am I missing anything?
Anyway, I go to the site I want mapped and I enter the domain, click on the 'Map Domain' button and the gif animation comes on then goes off and nothing is mapped. The input box remains empty after I click on Tools>Domain mapping.
Meanwhile when I try to access the domain it redirects to the main mutlisite which confirms the 'A' record is working as it should...its just not being mapped at my multisite. Please advice. Thanks

  • dipopeters
    • WPMU DEV Initiate

    I just logged out now and cant login again. I placed the code 'define( 'SUNRISE', 'on' );' directly above '/* That's all, stop editing! Happy blogging. */ as instructed.

    When I remove the code I'm then able to login to the admin. So how do I get this thing working?

  • Ivan
    • HummingBird

    Hey Dipopeters,

    Thanks for the question.

    Can you check the sunrise file permissions and ownership?
    It should be owned by the same user that own the rest of the files, and permissions need to be '755'.

    Additionally you can grant us support access to see if we can help somehow from there.

    Thanks,
    Ivan

    • wp.network
      • The Bug Hunter

      @Ivan Denkov 755 really?

      that seems really weird to me; why would public need execute access?

      I have mine set to 640 with no problems, 644 obviously works too...
      even 744 would seem better (more secure) than 755... perhaps some folks would need 754...

      can you explain why 755 is needed & where this is documented?

      Cheers, Max

  • dipopeters
    • WPMU DEV Initiate

    Thanks for the prompt response. I've changed the permission to 755 but no changes when I try to map the domain. I can create an admin user for you to login and try, please send me your email address so I setup a user account for you. Also, how do I send my FTP login to you privately?

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, dipopeters!

    Can you send me some info privately, via our contact form?

    https://premium.wpmudev.org/contact/

    Subject: "Attn: Michelle Shull"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me. :slight_smile:

    I can take a closer look this way.

    Thanks, dipopeters!

  • dipopeters
    • WPMU DEV Initiate

    Hello,

    I've just sent you the email with all the details you requested for. Please note that I've had to deactivate the plugin for now because when it's activated and I have the code in wp-config I'm unable to login to the dashboard until I remove the code...I dont know why this happens but I guess once you've checked it outand fixed it all well be well.

    • wp.network
      • The Bug Hunter

      @dipopeters this might take a day or more for staff to look into carefully, fyi

      Personally, I have a hard time just waiting too :slight_smile:

      I usually and up deleting and trying again a few times in-between support responses; this works for me in part because I have a great backup/restore system in place... hope you can get this sorted :slight_smile:

      Kind Regards, Max

  • dipopeters
    • WPMU DEV Initiate

    Hello,

    It's been days now since I was promised my issue would be looked into by Michelle, I've submitted my FTP and wp-admin login details already as requested and still no response. I really need this domain mapping to work as a lot is riding on this. Please help get it to work.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hello there dipopeters!

    Thanks so much for your patience here, there's been an influx of new members and new topics, so response times are slower than we'd like.

    I found this reply from Ash to a member with a nearly identical problem to yours:

    Would you please right click on Chrome browser > Select Inspect Element > Select Console tab > Refresh the page and try to map again. Look at the console tab if any error is appeared in there.

    If not, go to Network Admin domain mapping settings and disable DNS verification of mapped domain, then try again in subsite.

    Can you try these steps and see if that helps?

    Thanks!

  • dipopeters
    • WPMU DEV Initiate

    Hello Michelle,

    I'm appealing to you to take a few moments and just login with the details I've sent already. Everything I need to do with this site is on hold now until I can get this to work. I've followed every instruction step by step and I cant get it to work.

    Please help!

  • Michelle Shull
    • DEV MAN’s Apprentice

    Dipopeters -

    Did you find any errors in the console when you tried to map your domain?

    I see one potential issue. When you added the define sunrise on line to your wp-config file, did you add this:

    define('SUNRISE', true);
    or
    'define('SUNRISE', true);'

    If it's the second one, we've found your issue. That would cause everything to fail much like you describe here. Remove the single quotes, and try again.

    Thanks!

  • dipopeters
    • WPMU DEV Initiate

    Thank you for your response. If you scroll up you'll see in one of my responses that I've had to deactivate the plugin because I'm unable to login to my dashboard when it's activated. I've longed since sent my ftp and cpanel login details also.

  • Hoang Ngo
    • Code Slayer

    @dipopeters,

    I'm sorry about that. I've checked your video, hmm, from here I can say when you clicked on the button, the request has been made to the server, but some server side code go wrong there, making it stuck.

    I'm trying to check your error logs from FTP, but I can't find any errors relate to Domain Mapping.

    For now, may I re-active the plugin just for some quick tests?

    Please advise,
    Thanks!!!

    Best regards,
    Hoang Ngo

  • Hoang Ngo
    • Code Slayer

    Hi @dipopeters,

    I hope you are well today and I'm sorry for the delay.

    I was trying to investigate the issue, actually the error because Domain Mapping using a 3rd plugin, which need PHP 5.3+ for working properly(it's using late static binding feature of PHP 5.3)

    Personally, I think you should update the PHP version to at least 5.3, the 5.2 is quite old (about 5 years after the last version release).

    Best regards,
    Hoang Ngo

    • wp.network
      • The Bug Hunter

      Personally, I think you should update the PHP version to at least 5.3, the 5.2 is quite old (about 5 years after the last version release).

      Word. I'd say go to at least 5.4 if possible :slight_smile:

      @Hoang Ngo if 5.3 is now minimum for use w/ Domain Mapping as your comment above seems to indicate then the usage page should be updated to reflect such, imho.

      Kind Regards, Max

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.