When I edit and save in Upfront, nothing is saving. Had

Hi guys,

When I edit and save in Upfront, nothing is saving.

Had some live support from Jude who suggested turning off all plugins. I’ve done that and it is still not saving.

I have tested this in both Chrome and Firefox – it’s not saving in either.

Support access has been granted.

Host: JustHost

PHP: 5.4.43

Please help :slight_smile:

Thanks,

Scott

  • Predrag Dubajic
    • Support

    Hey Scott,

    Hope you’re doing well today :slight_smile:

    I have checked your site and I can see there are some errors in console when trying to save changes made in upfront.

    Could you try adding this rule in your .htaccess code and tell us if it’s working after that?

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    Best regards,

    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hello Scott,

    I hope you’re well today and don’t mind me jumping into this conversation.

    The code my colleague @predrag Dubajic shared is intended to disable Apache “mod_security” rules and is proven to work in most cases on SiteGround servers and with some other providers. It is however possible that JustHost dosn’t allow such action.

    That said, I’d like to ask you to try two more ways. First would be adding this code at the very top of your .htaccess file (instead Predrag’s code!):

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    Second one (in case this doesn’t work either) would be contacting JustHost tech support and asking them to disable mod_security for you. They should be able to whitelist your domain in mod_security rules and according to this post this shouldn’t be a “big deal” for them :slight_smile:

    Keep me updated please!

    Adam

  • Scott Colenutt
    • WPMU DEV Initiate

    Hi Adam,

    Thanks for all those suggestions. Unfortunately, none of them have worked and I don’t really know what to do next.

    JustHost has confirmed that mod_security is disabled. Support Access is enabled for you guys if you wanted to test.

    Thanks,

    Scott

  • Predrag Dubajic
    • Support

    Hi Scott,

    That’s strange, issues you are having are usually resolved by above suggestions.

    It looks like support access is expired so I couldn’t have another look at your site.

    Can you please grant it again?

    Note that support access expires 72 hours after granting it.

    Best regards,

    Predrag

  • Scott Colenutt
    • WPMU DEV Initiate

    Sure.

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index.php$ – [L]

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]

    </IfModule>

    # END WordPress

    # Set PHP handler to application/x-httpd-phpbetas on Mon Nov 23 19:17:38 MST 2015.

    AddHandler application/x-httpd-phpbetas .php

  • Predrag Dubajic
    • Support

    Hi Scott,

    Hmm, that's strange, nothing there that could be causing this…

    Could you provide us with your FTP login details so we can investigate this further?

    You can send us your details using our contact form https://premium.wpmudev.org/contact/ and the template below:

    IMPORTANT: Make sure you select "I have a different question" for your topic so it doesn't go back to forums – this and the subject line ensure that it gets assigned to me.

    Subject: "Attn: Predrag Dubajic"

    – WordPress admin username

    – WordPress admin password

    – login url

    – FTP credentials (host/username/password)

    – link back to this thread for reference

    – any other relevant urls

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Scott,

    Thanks for sending those in, I did some further testing and everything is pointing to mod_security.

    I know that you mentioned above that the JustHost confirmed that it’s disabled but could you have another chat with them following the suggestion from below thread and see if you can get any additional info from them.

    https://premium.wpmudev.org/forums/topic/upfront-panino-theme-changes-not-saving#post-931821

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Scott,

    Let us know of their response, also if mod_security is disabled then this message shouldn’t show when you go to YOURDOMAIN.com/etc/password/

    Not Acceptable!

    An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Scott,

    So they first told you that the Mod_Security is turned off but then they still send you to article for disabling it via .htaccess, strange…

    I checked your .htaccess again and tried applying some additional rules but nothing is giving any effect, it looks like the server it’s not allowing this to be disabled via .htaccess.

    I’m pretty sure that this is something your host should be able to resolve or at least tell you why the .htaccess changes don’t take effect, but just in case I’m going to flag this thread for our developers so they could check if there’s anything I’m missing.

    Best regards,

    Predrag

  • Scott Colenutt
    • WPMU DEV Initiate

    Hi Predrag,

    Did any of your other developers have chance to look into this yet?

    I’ve been away for the holidays so haven’t followed up again with my host yet. Thought it would be best to wait and see if there’s anything else you guys could find.

    Thanks,

    Scott

  • Predrag Dubajic
    • Support

    Hi Scott,

    Apologies for missing this thread, I did get some feedback from the devs couple of days ago but I forgot to update you here.

    Unfortunately there doesn’t seem to be a way to change this from our end, the .htaccess rules are not being applied and that’s something that your host can resolve for you.

    Upfront developers are still looking for ways to go around this issue that is happening on some servers.

    Best regards,

    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hey Scott,

    I really hope that your host’s techs will carefully review your server’s configuration and be able to tweak it in a way that will solve the issue. In case they’d ask you for any specific “requirements”/setup options necessary, please let us know and we’ll ask our developers.

    As for devs progress.

    Unfortunately I’m not able to give you any predictions on when and what will they do because issues such as this one are often very difficult to diagnose and override and it may take some time. Also their current schedule is constantly changing due to the very different nature and number of other issues being reported.

    That said, apart from keeping themes/plugins updated it’s always good to keep an eye on product’s changelog where most important changes are published. While you’re logged in to your WPMU DEV account here, you will find a “changelog” link on description pages for every plugin and theme.

    Best regards,

    Adam

  • Scott Colenutt
    • WPMU DEV Initiate

    Predrag/Adam,

    The plot thickens…

    After a few more emails with my host, they have said the following:

    “So on our shared servers we cannot disable mod_security. We can whitelist rules once we see that show up as being broken/hit with mod_security. So if you are getting a error with mod_security let us know and we could whitelist the rule that is being hit.”

    Could you/would you be able to help in detailing the rules that are broken?

    Thanks,

    Scott

  • Scott Colenutt
    • WPMU DEV Initiate

    Hi guys,

    Thought I would give an update on this after several emails back and forth with my host over the last month.

    In short, this is still a problem for me. My host (JustHost) has told me that changing mod_security is not possible on my current hosting package (basic, shared hosting).

    I have to upgrade to a VPS hosting option with them in order to be able to configure mod_security.

    I’ll be doing this shortly, so I will keep you updated with whether this solves the problem or not.

  • Scott Colenutt
    • WPMU DEV Initiate

    Hi guys,

    It works!

    After some back and forth with my hosting provider, JustHost, I eventually upgraded to their standard VPS option (switching from a mid-range shared server option).

    After I done this, I was able to implement the mod_security code referenced earlier in this thread and I am finally able to edit using Upfront.

    Definitely worth any JustHost customers knowing this!

  • Milan
    • WordPress Wizard

    Hello Scott,

    I hope you are having a good day.

    Thanks for sharing solution which worked for you with us. :slight_smile: We are really glad that you invested your time to reply us back here with solution. :slight_smile: Thanks a lot for your this effort. :slight_smile:

    Now as this thread is reached to its solution. I am marking this as resolved and you don’t need to reply me back here. :slight_smile: If in case you face any other issue with product and have something to clear up in your mind, please issue new thread from here,

    https://premium.wpmudev.org/forums/#question

    Thanks for being with us. Enjoy WPMU DEV. :slight_smile:

    Best Regards,

    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.