when I go to my sub site: academy.findhopetoday.com, it

when I go to my sub site: academy.findhopetoday.com, it redirects to https:// instead of http://

I add domain mapping is http but why it redirect to https:// and the sub site can not show.

I tried to delete domain and add again, but still got the same issue. Please help!

  • Bojan Radonic
    • Head of Support

    Hey there @Jason, hope you're well today!

    @Bjørn Thanks for helping :slight_smile:

    As Bjørn suggested .htaccess would be a good place to start. Also you could check your wp-config.php, make sure that your home and site URL are not using https:

    define('WP_HOME','https://domain.com');
    define('WP_SITEURL','https://domain.com');

    While you're there make sure to set

    define('FORCE_SSL_LOGIN', false);
    define('FORCE_SSL_ADMIN', false);

    Hope this helps.

    Cheers,
    Bojan

  • Jason
    • The Bug Hunter

    Hi,

    I checked htaccess and wp-config also. It seems everything is ok. And note that other sub sites work normally, only this sub site can not work.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    define( 'WP_SITEURL', 'http://missionwebs.org' );
    define( 'WP_HOME', 'http://missionwebs.org' );

    define( 'FORCE_SSL_LOGIN', false );

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.