When I go to shopping cart it always says your shopping cart is empty

I also have an issue with the WP Twenty Ten Theme that I use. When I am in dashboard and go to visit site It takes me out of the dash board.
I have the checkbox checked to keep the dashboard visible but makes no difference.
Any ideas.
Chris

  • Patrick
    • Support Monkey

    Hi there @Chris

    Welcome to the forums, glad to have you aboard!

    Please only post one issue per thread to keep support on-topic and focused on a single issue. Thanks!

    I just visited your site and see that all store links open in new windows. Please check under Appearance > Menus to ensure that the "Open in new window" checkbox is not checked (screenshot).

    There is also an issue with the URL for your products page. It appears like this:
    http://www.boatgear.info/shop-spares/productsmp_cart_link/

    ...whereas it should be like this:
    http://www.boatgear.info/shop-spares/products/

    Unfortunately, we cannot assist you with any theme issues you may be experiencing as your membership here at WPMU DEV only covers support for your MarketPress plugin. But I can recommend updating to a more recent theme to avoid problems, as the 2010 theme is a very old theme and will likely not be maintained in future.

  • PC
    • WPMU DEV Initiate

    Posting here to keep the issue on a single thread.

    Hello there Chris,

    I see @Vinod Dalvi has suggested you the below on a thread you have posted for the same issue.

    Hi Chris,

    Thank you for your question and sorry to hear of the problems you are having.

    I checked your site and found you are using WP Super Cache plugin which may be causing this issue.

    Could you please try clearing cache or deactivating WP Super Cache plugin to test is this a plugin which is conflicting?

    Kind Regards,
    Vinod Dalvi

    Can you kindly disable that plugin and as advised by Patrick, check with one of the latest WordPress default themes (2014) to see if that works ?

    Kindly post your response on this thread itself.

    Cheers, PC

  • Chris
    • WPMU DEV Initiate

    Hi,
    Sorry about starting so many threads, couldn't work out how to reply in thread! (wasn't signed in!).

    OK I have tried deleting all plugins and just the super cache, I have tried using the 2014 theme. I get exactly the same problem, Cart does not show more than one product at a time and when I go to checkout "There re no items in you cart".

    Regards
    Chris.

  • Chris
    • WPMU DEV Initiate

    Hi Patrick,

    Thank you for your reply, I had just found the answer and got the site back up and running 15 minutes before.

    The problem was a setting on the wordpress general setting page which had been altered. Site address had been changed from http//boatgear.info to http://www.boatgear.info when this was changed back to the original everything worked.

    Took a bit of finding and have no idea how it was changed. but this has also put my logins on wordpress back to normal and I now have no issue with computers running XP which we did before.

    Thanks for your help.

    Regards

    Chris

  • PC
    • WPMU DEV Initiate

    Hey there Chris,

    Glad to see this is resolved.

    Sorry for the delay in response as I was away due to bad health and could not get back to this any sooner. Please accept my apologies for the uninformed delay and any inconvenience it may have caused.

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.