When I try to activate theme, I get the following message:

When I try to activate theme, I get the following message: Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/hierarchy/public_html/wp-content/themes/upfront/library/servers/class_upfront_javascript_main.php on line 229

  • Vaughan
    • Support/SLS MockingJay

    Hi @telakayne,

    Hope you’re well?

    This error means that your servers PHP version is too old, usually you get this with PHP 5.2.x versions.

    Without redeveloping the theme, it is probably easier to ask your webhost to upgrade your PHP on the server to the latest release (at a bare minimum, you should want 5.3.28)

    But 5.4 or 5.5 would be better. PHP 5.2 has reached end of life and is no longer updated or supported, so it’s in your best interests to ask your host to update anyway, it will also be more securer than using 5.2.

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.