when I try to map a domain I get an error saying

when I try to map a domain I get an error saying The DBname.wp_domain_mapping table is missing. I checked the DB and confirmed it is missing.

  • Tyler Postle

    Hey William,

    It should have automatically created this table when you installed Domain Mapping. You can either create it manually or you can try re-installing Domain Mapping to have it automatically create it.

    ***If you go with option 2. Then make sure you delete the following row inside the wp_sitemeta table:

    domainmaping_database_version

    Steps would be:

    1. Delete Domain Mapping

    2. Delete the domainmaping_database_version row

    3. Re-install/activate Domain Mapping

    The reason we need to delete that row is because if it exists then it will always maintain the existing state of DM, so it won't think that it needs to create the domain_mapping table. We want it to think you are installing DM for the first time.

    Or you could just create the wp_domain_mapping table.

    If you aren't comfortable making changes to your db then you can send us your cPanel and we can make the changes for you :slight_smile: just make sure you do a full backup before hand to be on the safe side.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -cPanel credentials (login url/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.