When logging in using Ultimate Facebook plugin, the plugin won't refresh the page

When logging in with Ultimate Facebook plugin, I'm not redirected and instead facebook's loading icon is displayed until I refresh the page manually.

  • Patrick

    Hi there @Oleg

    I hope you're well today!

    I just tested the Facebook login on my test network and it redirects correctly after logging in, without needing to refresh manually.

    I did manage to create an account on your site on the 2nd try using the Facebook login button. There may be cache or some other script on your site that may be interfering.

    Seeing that you had granted support access, I logged into your site, but nothing obvious jumped out at me.

    Please implement basic troubleshooting protocol as illustrated on the following page to locate any possible conflicts:

    Once we have zeroed in on what may be causing this, we'll be better equipped to deal with it.

  • Sajid

    Hi @Oleg

    Hope you are doing good today :slight_smile:

    I tested on your website and it did worked for me on second attempt. But on my own test sites its worked at first attempt and successfully redirected me to profile page after login. Its may be because you are using it in popup/modelwindow. Test it with normal page and let us know if that helps.

    For login callback, I am not sure if there is any but I am flagging SLS (Second Line Support) to chime in and provide their invaluable feedback on this matter. He will post a reply here as soon as possible depending on his workload.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Oleg

    So facebook surly does have a login event an it'll look something like:

    // In your onload method:
    FB.Event.subscribe('auth.login', login_event);
    // In your JavaScript code:
    var login_event = function(response) {

    but it doesn't trigger for some reason... The modal should have nothing to do with it. It's just a hidden and shown again html element, not a separate window.

    It works from the second time but it should work from the first.

    I use a few hook on after_setup_theme, can it be related? Can other hooks be related? What can cause this?


  • Sajid

    Hi @Oleg

    Hope you are doing good today :slight_smile:

    I got the developer feedback and he says the code is commented in the plugin. Did you or any one else modified the code ?

    If yes, then please take a backup of this plugin, delete it from plugins and then install the fresh copy from WPMUDEV again. Now clear the cache and then check.

    Also send me WordPress admin login and FTP details if in case we need that. You can send that through in following format. Also include the necessary information in email that are related to this issue. For example code, changes special plugins functionality etc... (if any).

    Subject: "Attn: Sajid Javed"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:


    Take care and have a nice day :slight_smile:

    Cheers, Sajid