When will WPMU plugins be Buddypress 1.2.10 compatible?

Hi there.. just a general question about BP 1.2.10. Does anyone know about how long after a Buddypress update is it safe to actually apply the update? My concern is the WPMU BP plugins that I've installed. Should I be waiting to apply BP's update or should I wait for WPMU to catch up and okay that their plugins are compatible with those new changes before proceeding?

Thanks!