Where Am I going Wrong

Move Blogs.php

///DB Settings
$dbname="db402620780"; //This is your current database
$blog_table_prefix='wp_'; //Prefix of your wpmu blog tables, most likely this won't need to be changed
$newdb_prefix='wp_2'; //This is the prefix of the db's you're moving your tables into - we assume they are all the same, if not, you're in trouble

//We need info to connect to the databases
$dbhost='localhost:disappointed:tmp/mysql5.sock';
$dbuname='dbo402620780';
$dbpass='cdyy37zw';

//How many db's are you moving into (16, 256, or 4096)?
$db_scaling='16';

DB-config

//---DB Scaling-----------------------------------------------------------//
//------------------------------------------------------------------------//
// 16,256,4096
define('DB_SCALING','16');
//------------------------------------------------------------------------//
//---DC IPs---------------------------------------------------------------//
//------------------------------------------------------------------------//
// Usage: add_dc_ip(IP, DC)
// EX: add_dc_ip('123.123.123.', 'dc1');
add_dc_ip('///DB Settings
$dbname="db402620780"; //This is your current database
$blog_table_prefix='wp_'; //Prefix of your wpmu blog tables, most likely this won't need to be changed
$newdb_prefix='wp_2'; //This is the prefix of the db's you're moving your tables into - we assume they are all the same, if not, you're in trouble

//We need info to connect to the databases
$dbhost='localhost:disappointed:tmp/mysql5.sock';
$dbuname='dbo402620780';
$dbpass='cdyy37zw';

//How many db's are you moving into (16, 256, or 4096)?
$db_scaling='16';
','dc1');
//------------------------------------------------------------------------//
//---Global Tables--------------------------------------------------------//
//------------------------------------------------------------------------//
// Do not include default global tables
// Leave off base prefix (eg: wp_)
//
// Usage: add_global_table(TABLE_NAME)
// EX: add_global_table('something');
//add_global_table('global');
//------------------------------------------------------------------------//
//---DB Servers-----------------------------------------------------------//
//------------------------------------------------------------------------//
// Database servers grouped by dataset.
// R can be 0 (no reads) or a positive integer indicating the order
// in which to attempt communication (all locals, then all remotes)
//
// Usage: add_db_server(DS, DC, READ, WRITE, HOST, LAN_HOST, NAME, USER, PASS)
// EX: add_db_server('global', 'dc1', 1, 1,'global.mysql.example.com:3509','global.mysql.example.lan:3509', 'global-db', 'globaluser', 'globalpassword');
//
// Note: you can also place this section in a file called db-list.php in wp-content
add_db_server('global','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403096801','dbo403096801','cdyy37zw');

add_db_server('0','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097104','dbo403097104','cdyy37zw');
add_db_server('1','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403096849','dbo403096849','cdyy37zw');
add_db_server('2','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403096920','dbo403096920','cdyy37zw');
add_db_server('3','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403096985','dbo403096985','cdyy37zw');
add_db_server('4','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097156','dbo403097156','cdyy37zw');
add_db_server('5','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097221','dbo403097221','cdyy37zw');
add_db_server('6','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097234','dbo403097234','cdyy37zw');
add_db_server('7','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097328','dbo403097328','cdyy37zw');
add_db_server('8','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097406','dbo403097406','cdyy37zw');
add_db_server('9','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097459','dbo403097459','cdyy37zw');
add_db_server('a','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097515','dbo403097515','cdyy37zw');
add_db_server('b','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097617','dbo403097617','cdyy37zw');
add_db_server('c','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097674','dbo403097674','cdyy37zw');
add_db_server('d','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097862','dbo403097862','cdyy37zw');
add_db_server('e','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403097939','dbo403097939','cdyy37zw');
add_db_server('f','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403098040','dbo403098040','cdyy37zw');

add_db_server('vip1','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock', 'db403098115','dbo403098115','cdyy37zw');
//------------------------------------------------------------------------//
//---VIP Blogs------------------------------------------------------------//
//------------------------------------------------------------------------//
// Usage: add_vip_blog(BLOG_ID, DS)
// EX: add_vip_blog(1, 'vip1');

add_vip_blog(1, 'vip1');
?>

  • aecnu

    Greetings Service2Me,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

  • Service2Me

    Hiya,

    No I am sorry to say this is still an issue for me.

    I will try to describe the problem again.

    I am on a managed 4 core server

    I have followed the instructions and am getting the following error.

    Houston, we have a problem!
    Looks like you need to create your new db's! If you're lucky, this
    link still works - click me
    Database Error: Access denied for user 'dbo402620780'@'%' to database 'c'

    Here is the config portion of the db-config.

    define ('DB_SCALING', '16');

    add_dc_ip('127.0.0.', 'dc1');

    add_global_table('global');

    add_db_server('global','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403096801','dbo403096801','xxxxxx');

    add_db_server('0','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097104','dbo403097104','xxxxxx');
    add_db_server('1','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403096849','dbo403096849','xxxxxx');
    add_db_server('2','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403096920','dbo403096920','xxxxxx');
    add_db_server('3','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403096985','dbo403096985','xxxxxx');
    add_db_server('4','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097156','dbo403097156','xxxxxx');
    add_db_server('5','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097221','dbo403097221','xxxxxx');
    add_db_server('6','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097234','dbo403097234','xxxxxx');
    add_db_server('7','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097328','dbo403097328','xxxxxx');
    add_db_server('8','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097406','dbo403097406','xxxxxx');
    add_db_server('9','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097459','dbo403097459','xxxxxx');
    add_db_server('a','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097515','dbo403097515','xxxxxx');
    add_db_server('b','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097617','dbo403097617','xxxxxx');
    add_db_server('c','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097674','dbo403097674','xxxxxx');
    add_db_server('d','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097862','dbo403097862','xxxxxx');
    add_db_server('e','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403097939','dbo403097939','xxxxxx');
    add_db_server('f','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403098040','dbo403098040','xxxxxx');

    add_db_server('vip1','dc1',1,1,'','localhost:disappointed:tmp/mysql5.sock','db403098115','dbo403098115','xxxxxx');

    add_vip_blog(1, 'vip1');

    Here is the move-blogs.php

    $dbname = "db402620780"; //This is your current database
    $blog_table_prefix = 'wp_'; //Prefix of your wpmu blog tables, most
    likely this won't need to be changed
    $newdb_prefix = ''; //This is the prefix of the db's you're moving
    your tables into - we assume they are all
    $dbhost = 'localhost:disappointed:tmp/mysql5.sock';
    $dbuname = 'dbo402620780';
    $dbpass = 'xxxxxx';

    $db_scaling = '16';

    I have not went live with the site yet and am considering doing a full reinstall to see if this will help.

    The database server is on the local host and the database naming convention shown above is not optional, so I need to work within this convention.

    Thanks

  • Loggy

    @S2M - you need to do various things.

    Here is a checklist. You have probably done some of these but I suspect the privilege is the issue. The tokens here ($dbuser etc) are extracted from php coding and will need customising for your setup:

    create user $dbuser@localhost;
    drop database if exists $database;
    create database $database;
    set password for $dbuser@localhost=password('$dbpassword');
    grant create,create temporary tables,select,insert,delete,drop,index,update,alter,lock tables on $database.* to $dbuser@localhost identified by '$dbpassword';
    flush privileges;

    Your MySQL user and password has nothing to do with your FTP user and password!!!

  • Service2Me

    @ Loggy

    Sorry you have lost me there.

    I have been over the databases and they are created and the user names and passwords are correct with full privileges. I am following the install instructions to the letter and have come up with the same error. I have tried different permutations of common ways to address the Mysql instance in the config files and have come up with the same error with very little variation.

    The Multi-site network is working perfectly off the single database and I am finding it difficult to understand why the move-blogs.php is unable to access that database and is not accessing any of the others.

    I am beginning to suspect that this plugin is unable to work with the ( localhost:disappointed:tmp/mysql5.sock ) addressing convention as well as the fact that each database has a unique user name and unique DB name with no Prefix.

    I wanted to go with a pure WPMUDEV solution for what I am doing, yet I am going to need to look at some other way to do this.

  • Mark de Scande

    @Service2Me START OVER :slight_smile:

    I was looking at your settings and i know for a fact they are wrong

    Open wp-config.php and make an note of the db user and pass now add it in here

    $dbname="db402620780"; //This is your current database

    i bet you this is wrong (if you have cpanel go to dbs and make sure about it 99% of the time it would be the same as your cpanel account name )
    $newdb_prefix='wp_2'; //This is the prefix of the db's you're moving your tables into - we assume they are all the same, if not, you're in trouble

    These details you can copy from wp-config
    $dbhost='localhost:disappointed:tmp/mysql5.sock'; (this is wrong it should be "localhost")
    $dbuname='dbo402620780'; (i bet you this is wrong)
    $dbpass='cdyy37zw'; (i dont think it should be so sort)

    I hope this helps to get you started :slight_smile:

    Just by the way i will be posting a how to set up MultiDB just give me a day or show

  • Service2Me

    Hi All,

    Thank you for all of the replies.

    I see where you are all going with the querys...

    I am using a server that is half way between a full dedicated server with a full c-panel and the usual hosing package where you have no real control and are on shared space. So I do have dedicated hardware and capability yet do not have full control.

    This is why to you the DB names, User names and host addressing seems odd to you.

    So here is what I am going to do. I will stay with the single database and go live with it. If the service that this portion of the business grows to the point where I need to move to multiple databases, I will be wanting to buy a dedicated server with PLESK and then will most likely come here and hire someone to migrate it.

    Thanks for the input.

    Please close this thread.

  • Grace n Ease

    "$dbhost='localhost:disappointed:tmp/mysql5.sock'; (this is wrong it should be "localhost")
    $dbuname='dbo402620780'; (i bet you this is wrong)
    $dbpass='cdyy37zw'; (i dont think it should be so sort)"

    Personally, I have never seen cpanel work that way.
    That's interesting.

    It's always been "localhost"
    And the account name with a _ then the database name.

    The password looked a little short, but if the security isn't forcing secure passwords I guess it would work. Mine are always 12 charactors long, but I use the automatic generation so I know the software likes what I put in.. lol

    I got errors too, but it was just my understanding (or lack thereof) of what exactly I needed.. There is just a tiny bit of confusion in the way the instructions are spelled out, but next time I will have no confusion. I got it.. Thanks for another great plugin..

    It's really easy now that I got it done..

    I know this thread is older and it was asked that the topic be closed, but I just wanted to make an observation. I hope nobody minds.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.