Where do I find information about server level system

Where do I find information about server level system requirements for the plug-ins on your site?