Where is my single.php?

I'm trying making my wp site with upfront builder and "Luke + Sara" Theme.

But I can not display my post page with single.php, it's display with index.php.
I tried edit&save single.php in upfront builder's editor again and again.
But nothing changed.
Why?

  • Predrag Dubajic

    Hi soupstudio,

    Hope you're doing well today :slight_smile:

    Can you tell me if this issue was happening from start or you just recently started experiencing it?

    I tried restoring your site on my local installation by using snapshot from your site and I had no issues with the posts showing as index.php and they were all displaying correct content for me there.

    Based on this it looks like there were some changes in the meantime that might have caused this.
    Snapshot I used from your site seems to be from yesterday so do you remember the changes you made the last day that might be affecting your posts?

    Best regards,
    Predrag

  • soupstudio

    Hi Predrag,

    I changed a lot of thing after snapshot....nn

    1) Index's slide images could not display.
    After I changed some images, all displayed.

    2) I tried to make a toggle menu for mobile,
    But I couldn't understand how to display toggle icon.
    So I installed other Theme "Fixer" and research the menu structure in Upfront Builder's Editor.
    I gave up to make it. < this is next problem for me.

    3) I tried to use Humming Bird plugin, once activate and I deactivated it soon.
    Because I thought Minify will break some page layout..

    I remembered such thing.
    after (3),I noticed the problem.

    Thanks,

  • Predrag Dubajic

    Hi soupstudio,

    I did another test with your installation, this time by creating new snapshot that has the latest version of your setup and I was able to replicate the same issue when restoring it on my local site.

    I was unable to pinpoint the exact cause of why this started happening as I'm not familiar with the changes you did, but the good news is that I was able to reset single post layout directly from Upfront settings and that got the single posts look back.

    So all you should do is go to Upfront > General panel and reset Single Post layout:

    I would usually suggest creating a backup before performing something like this but since I created it already for testing I'll leave the snapshot backup so you should be good to go.

    For the responsive menu issue, again, I'm not sure about the changes you've already made since the menu is there but the menu trigger is not visible, what you can do now is go to UF responsive mode and edit menu preset CSS where you can add some code like this:

    [data-style='burger'] .responsive_nav_toggler {
        background-image: url(MENU_ICON_URL);
        background-size: contain;
        border-radius: 0;
    }

    In there change MENU_ICON_URL with URL to image you want to use as your responsive menu and that should do the trick.

    If you require additional help with setting up the menu please start a new thread as the issue is not closely related to your original one and having separate threads will help us keep better track of everything and make sure we provide you with better and faster responses.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.