Where is the actual .xml Sitemap on Multisite Sitemap?

I have installed Multisite Sitemap on all of my sites and it has created a sitemap.php file for each domain and sub-domain. All is great in that respect except that I need to edit the sitemaps for files that I don't want indexed.

Where do I find the actual sitemap.xml file?

Thank you.

  • Kasia Swiderska

    Hello Mary,

    That plugin does not create actuall xml files. They are generated by sitemap.php files "on the fly" - so you cannot edit xml files.
    If you take a look on usage page there is instruction to add this line

    RewriteRule ^(.*/)?sitemap.xml wp-content/sitemap.php [L]

    to htaccess - that is rewrite rule, so when you go to (for example) https://chat.christiangays.com/mary-content/sitemap.xml you actually open https://chat.christiangays.com/mary-content/sitemap.php

    I dont see way to exclude items in that plugin without changing code of it.

    Maybe instead this plugin SmartCrawl will be better choice https://premium.wpmudev.org/project/smartcrawl-wordpress-seo/ as it allow for site map customization.

    kind regards,
    Kasia

  • Nithin

    Hi Mary,

    Hope you are doing good today. :slight_smile:

    In order for the plugin to generate sitemaps according to each subsite, you'll first have to make sure the sitemaps settings is accessible in your subsite by enabling Allow Site Admin access to Yes.

    You'll have to make sure to add the following line in your wp-config.php file to make this work:
    define( 'WDS_SITEWIDE', false );

    Once done, in your subsite under Settings > SmartCrawl > Sitemaps, you'll find the path where the sitemaps are located.

    You can then edit these according to your requirements, I hope this helps. Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Mary

    Thank you Nithin. I found the sitemap.xml file for the main site in the uploads. I am wondering why they would be in uploads when I put the path to public_html. I have changed the path to uploads now but would have preferred to have it in my public_html folder.

    Also, I can't find the sitemap.xml files for the sub-domains chat and dating. If I FTP to sub-domain the sitemap that is there is the one for the main site, not the sub-domain.

    And finally, I have ticked off to exclude forums but forums keeps showing up in my sitemap. How do I exclude the forums from being indexed?

  • Nithin

    Hi Mary,

    Hope you are doing good today. :slight_smile:

    I found the sitemap.xml file for the main site in the uploads. I am wondering why they would be in uploads when I put the path to public_html. I have changed the path to uploads now but would have preferred to have it in my public_html folder.

    By default the sitemap.xml is generated by the plugin, inside the /uploads/ folder. If you want to change the path, you'll have to make sure that the sitemap.xml file is located in that particular path, maybe there is a permission issue, hence the file is not being created in your suggested path. Creating a sitemap.xml, and re-saving the settings should make this work.

    Also, I can't find the sitemap.xml files for the sub-domains chat and dating. If I FTP to sub-domain the sitemap that is there is the one for the main site, not the sub-domain.

    As mentioned above, you'll have to add the following line in your wp-config.php:
    define( 'WDS_SITEWIDE', false );

    This will remove the SmartCrawl settings from the network admin, and will enable the settings for each subsite. You'll then have to configure the sitemap for each subsite. Please do note that you'll only have access to settings, to which you have enabled through Allow Site Admin access option.

    And finally, I have ticked off to exclude forums but forums keeps showing up in my sitemap. How do I exclude the forums from being indexed?

    I have excluded topic tags form the taxonomies, and now the forums seems to be excluded form your sitemap. Please check, and confirm.

    I hope this helps. Please advise if I had missed out anything. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin