Which Pages Should Be Visible before Signup?

I was logged out.

1. I clicked on the Members page - and it shows me the members.
2. I clicked on the Activity page - and it takes me to the registration/log-in page.
3. I clicked on the Groups page - and it shows me all the groups.

Is this correct? I would think you need to be logged in to see Members or Groups as well as Activity.
Why is that login only happening on the Activity page.

I have Members as a sub-menu (under PAO Community as the main tab) with Activity and Groups hanging off the Members sub-menu.

Thanks.

  • Karen

    Ari

    No rules at all that i know of unless done accidentally.

    No, I have just checked all my Membership Subscriptions and while they are active - I have not yet added any restrictions to any of them.

    Feel free to go in and have a look (I think I sent you the access details some time earlier) and tell me if I am doing something wrong (chances of that are probably pretty high.)

    I think i am unclear on how Buddypress and Membership plug-ins work together - and which pages / features belong to which - but I have asked Vinod in another thread. Any clues/pointers for clarification appreciated!

    Thanks for your help.

  • Karen

    Ari

    I seem to have just got the WSOD (white screen of death) - have removed plug-ins and changed the theme and back to bp-fun, but all has disappeared. I am not sure if anyone was trying to access it but now I am stuck for what to do. Any help appreciated as nothing on my site is showing. I had been fiddling with the access levels and postive and negative rules, but reversed them all when my site would not load. Went to my host and the site isn't down. The only suggestion left (after removing plug-ins and themes) is the .htaccess file (I know nothing about but guess I am about to find out). FYI.

  • be

    Hi Karen, till a staffer gets here.

    WSOD is usually no major biggie (apart from the fact no one can see your screen of course:slight_smile:

    If you have made no changes to php or operating files (often relates to unclosed tags and such)
    Check -

    What was the last change made backend ?
    Do you have cpanel access?
    Do you have any cache plugins?
    or do you believe it is member access? (not likely as you would normally get a home page etc)

  • Karen

    Be

    Thx for the response. After hours (all day) online it was a permalink issue. I see from the community that this - especiallyin the last 13 hours when someone else had it - it appears linked to market press which I have installed.

    Re other questions:
    1. i removed all cached history -it didn't fix the problem.
    2. My host got me to remove plugins, theme and also do a new .htaccess file -still no access.

    The only thing that worked was re saving the permalink a (click the button inset things). No idea why that would fix things. They could not tell me how often that needs to be done either. Do you know?

    In the end i created a new plug in folder and moved the plugins one by one to test them as each was installed. Appointments+ was a problem -that gave me the WSOD! So I will have to reinstall from scratch.

    On another note: I had to reinstall WPMU dashboard. When I tried to it wanted me to add to a different site and ghosted out my ability to this site. Someone might want to look at that...as I can't be the only one with WSOD and have to reload to the SAME site. So that option needs to be there.

  • be

    The only thing that worked was re saving the permalink a (click the button inset things). No idea why that would fix things. They could not tell me how often that needs to be done either. Do you know?

    In around about way - in loose terms, when you mess around with code it can confuse some plugin paths - resetting the permalink structure and things go back to normal..
    Some plugins need a certain permalink structure and will usually advise this at install.

    I had to reinstall WPMU dashboard. When I tried to it wanted me to add to a different site and ghosted out my ability to this site.

    I would suspect this relates to the WPMU key as it is already activated on site A.

    Someone might want to look at that...as I can't be the only one with

    WSOD and have to reload to the SAME site.

    Are you saying you reinstalled your site?

    Appointments+ was a problem -that gave me the WSOD! So I will have to reinstall from scratch.

    What was the last change made in Appointments+ (if you know and undo it it will likely fix_

    Re caching - not sure if you are aware but you should not cache any ecommerce or shopping cart pages as this will give you and all customers a very unreliable experience.. :slight_smile:

  • Karen

    Hi Ari and Be

    Thanks for the answers.

    For no real reason, my site is working (touch wood).

    Appointments+ I hadn't touched it in a while as I had set and forgotten it while I got on with other plug-ins so it wasn't something I touched.

    I don't touch code (unless you count instructions above from Ari or the code given to me for the orange button on my site). I (a) don't know how to code and (b) don't want to! :slight_smile:

    Caching - umm that sounds serious. All I am doing is using the plug-ins as per the instructions. I was asked to clear the caches on my website to see if they were causing a problem - which I did and NO doing that didn't fix anything. I am hoping that the plugins - as is - don't do the nasty caching...I presume that isn't an issue for my site.

    As noted- it is working. No idea why it stopped. When I followed the hosting organisations instructions and renamed the plugins folder and created a new one and introduced them one by one and tested if the site worked - the ONLY plugin that made it go back to WSOD was the Appointments+ plugin. I tried it several times to make sure and it was always that plugin that sent me back to being a white screen. No idea why. Just reporting it so if someone (more cluey with IT) gets it, they can let you know.

    Ari - If I put that Debug in place (to true) my site is a mess and I have other people logging in to it to see it so can't afford to have that stuff all over it. If there was a way it was recorded somewhere else and left my screen / website pages alone I would do it. FYI. (Happy to take instruction on how else to do it).

    Thanks for all your help. Perhaps close the thread until the next episode occurs?

  • be

    To turn debug to log - you can add this instead.

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG',true);
    define('WP_DEBUG_DISPLAY', false);

    However be aware this file can get very large if lots is going on in a very short time.- so normally you only turn on debug when looking for a problem..
    Ie: if there is lots of info there you should get that sorted.. all those messages are telling you about problems with the site functions.

    So if you can maybe post the debug info as above for Ari to sort out the Appointments issue then those messages will go away..

    Caching WILL be a problem no matter what plugin it comes from on a shopping cart as it will not and cannot function as expected, customers will get all sorts of erroneous output.

    What caching plugin are you using?

    eg: WP Supercache is known to display very fast "white pages" on sites :slight_smile: which of course is NOT the desired outcome.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.