Which version of WordPress should I use for the Q&A plugin to work?

I see this:
You have version 1.4.5 installed. Update to 1.4.5.1. Compatibility with WordPress 4.5.2: Unknown
I'm not sure how to even tell if version 1.4.5 is compatible with WordPress 4.5.2