White screen issue on SEO checkup

When I'm trying to run SEO Checkup, it's redirecting me to a white screen.

  • Adam Czajczyk
    • Support Gorilla

    Hello twinsmagic

    I hope you're well today and thank you for your question!

    I checked your staging site as I'm not able to access the production one (due to lockouts). There was SEO Checkup module enabled but then the same module wasn't made "available" to the sub-sites (neither was SmartCrawl set to site-wide mode).

    To run the checkup on sub-site make sure that the SEO Checkup is enabled in Site Owner Permissions in SmartCrawl's settings in Network Admin area. I can confirm that this also works on your site.

    However, I admit I'm not sure why there was even a button displayed to run checkup. With the SEO Checkup disabled in Site Owner Permission options (as it was on staging site) there should actually be "Activate" button disabled that would take you (if you're logged in as a super-admin) to the settings where you could enable it. Was the checkup perhaps enabled there before (in Site Owner Permissions) and then disabled without running successful scan by any chance?

    Best regards,
    Adam

  • twinsmagic
    • The Incredible Code Injector

    I don't know the answer to that question unfortunately. This site was cloned yestereday to be make shift staging site. Feel free to remove any plugins and add them back. You have super admin access and nobody is using this site in real life.

    In CLoudflare, I did have auto-minify turned on for html, css, and JavaScript. I did turn that off for the time being to further troubleshoot.

    Thank you!

  • twinsmagic
    • The Incredible Code Injector

    The issue is resolved I'm just not sure how to prevent it in the future on MS. I believe it has to do with not setting the network default settings first. I'll try again with keeping Cloudflare minification turned on next time but first setting the network settings first.

    Thank you,

    David Farr

  • Adam Czajczyk
    • Support Gorilla

    Hi twinsmagic

    Yes, if you have/had such optimization options enabled in CloudFlare that might sometimes cause unexpected issues. It should be fine and compatible "with everything" but that's, well, just a theory and in practice it's not always that way.

    I would especially recommend also keeping their RocketLoader completely off for WordPress-based sites. It's supposed to be fully compatible but I've seen it causing various (and difficult to diagnose/solve) issues so many times that I just "don't trust it". It seems to be a great solution for simple, nearly static sites but not quite that good for more complex and "lively" sites. Please note though: it's just my personal opinion based on my observations of site's I've been dealing with.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.