White screen of death despite checking plugins/themes/htaccess

Hi there

I have a site hosted on GoDaddy and stupidly managed to delete the public_html folder containing the website, due to trying to add a test ftp user.

I managed to restore the wordpress folder and I can access the backend of wordpress now. I have done a reinstall of the last update of Wordpress to ensure the core files are as they should be. I also recreate the .htaccess file as couldn't get onto the front-end and just got a blank page. (the white screen!! Arrggh)

So I seem to have everything as it was but am seeing nothing. I have tried renaming plugins in case it was a rogue plugin file. Nothing. So renamed it back and then did the same with the theme folder to see if that was the issue.

So now I am a bit stumped. I am not sure what else to try as I have gone through the systematic problem solving on most forums under 'white screen of death'.

There must be something I am missing, but I think my knowledge just ran out!

Please help!!

  • minki_malkin
    • WPMU DEV Initiate

    Hi there. The only error message I am getting with both DEBUG options enabled is in the back-end WP Dashboard - this says Notice: add_object_page is deprecated since version 4.5.0! Use add_menu_page() instead. in /home/[sitename]/public_html/wpdevapp/wp-includes/functions.php on line 3707

    Nothing in the developer console within the browser as detailed in your link - when accessing the site itself.

  • minki_malkin
    • WPMU DEV Initiate

    This is a list of all the things I have done so far;
    Disabled all plugins
    Disabled all themes and reverted to default TwentySixteen (I don't get a preview in any theme)
    Checked for white space in wp-config.php and functions.php in theme.
    Uploaded new core files for wp-includes and wp-admin
    The only other things mentioned for this topic include using a cache plugin but none is running on the site
    Deleted .htaccess and reset using Permalinks save
    Checked the wp-config.php for any line which is not a WordPress default and comment out
    Tried to increase PHP memory within wp-config.php - checked memory and it is set at 90Mb
    Turned on debug but only a notice shows, no other errors ; add_object_page is deprecated since version 4.5.0! Use add_menu_page() instead...
    There appear to be no errors on Wordfence scan or diagnostics (and disabled Wordfence too in case a security aspect was causing the issue)
    Checked directory and file permissions

    I need to reiterate that deleting a test FTP account annoyingly deleted public_html the root folder (without warning!) so I had to run a restore of the Wordpress folder (installation in a subfolder, not in root), which seemed to work fine, I can access the admin panel, see everything but the site itself will not show. So I am obviously missing something else!

    At the moment I have an index.html file with a 'maintenance' message just so it is not completely blank. If I remove this, the site comes up with a blank page.

  • Luís
    • Support

    Hi minki_malkin ,

    Hope you're doing well today!

    Can you send us the FTP and database details of your website, so we can give a closer look to check if we are missing something? If yes, please send it privately through our contact form:

    https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - phpmyadmin/cPanel credentials (url/username/password)
    - Link back to this thread for reference
    - Any other relevant urls/information

    Cheers, Luís

  • minki_malkin
    • WPMU DEV Initiate

    Just to report here, I finally worked out what the issue was. As I had deleted everything from Public_html - and having to restore all folder and files, I hadn't realised that the new default index.php I had copied into the root folder needed to point to the WordPress install which had been installed into a different folder.

    So this
    /** Loads the WordPress Environment and Template */
    require( dirname( __FILE__ ) . '/wp-blog-header.php' );

    Had to be changed to
    /** Loads the WordPress Environment and Template */
    require( dirname( __FILE__ ) . '/{name of wordpress directory}/wp-blog-header.php' );

    Simple mistake and one I should have realised! Hopefully, this might help someone with the same issue.

    Thank you for your help.

  • Ash
    • WordPress Hacker

    Glad to know your issue is resolved and thanks a lot for sharing your solution.

    I would also recommend to use a backup service like Snapshot so that in such situation, you just need to install wordpress and then restore - will make the life easier.

    Have a good day!

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.