White Screen when saving menu

Another issue....that seems to be oddly occurring. Whenever I save my Menu, it goes to a white screen and does not save. I have attached a video.

https://www.dropbox.com/s/0pwip6ek0y9cgx4/White%20Screen.mov?dl=0

  • Rupok

    Hi Blake,

    This is really weird and should not happen. However, can you please turn on debug mode in WordPress? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, paste them to a text file and attach with your reply.

    This debug data will tell us why the page is showing blank after you save your menu. Please send your debug data as soon as you can. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska

    Hello Blake,

    Can you try again to generate debug log? On some servers it can take a while to show that file.
    If there still wont be anything change this line define( 'WP_DEBUG_DISPLAY', false ); to

    define( 'WP_DEBUG_DISPLAY', true );

    this way it should output that error on white screen.

    If there still wont be any results try to run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart). Let me know how it goes.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    kind regards,
    Kasia

  • Nithin

    Hi Blake,

    Hope you are doing good today. :slight_smile:

    I have determined it is the Smart Crawl plugin.

    I checked your website, and I could confirm the issue in your system, but I'm unable to replicate the exact issue in my test server. This could be any other plugin that's is causing a conflict, to troubleshoot this further, could we please perform plugin conflict test, so that we could have a better idea about this issue? Since your website is live, I didn't perform the conflict test.

    Does the debug.log file still give any clue regarding this issue, or still it doesn't get generated?

    Please do let us know so that we could give a closer look. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska

    Hello Blake,

    This is super weird. I tested on my site with settings like yours and I could not replicate at all. And white screen should generate debug.log :slight_frown:

    Could you please send in the following via our secure contact form? I found some previous emails from you with those credentials but they are not working now.

    https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here when you will send those

    kind regards,
    Kasia

  • Nithin

    Hey Blake,

    Hope you are doing good today. :slight_smile:

    Was wondering if you logged into the site anytime around 12:50AM on Dec. 14th? I received a notification an admin logged in from India with the IP of 202.83.XX.XX.

    The mentioned IP is generated form my system, I was troubleshooting your website. I checked your website, and I was able to generated debug.log file. And the logs indicated there is a conflict with W3 Total cache plugin:
    PHP Fatal error: require_once(): Failed opening required '/xxxx/public_html/wp-content/plugins/w3-total-cache/lib/W3/ObjectCache.php' (include_path='.:/usr/share/php') in /xxxx/public_html/wp-content/plugins/wpmu-dev-seo/wds-files/wds-core/admin/wds-core-taxonomy.php on line 87

    Since you had the plugin deactivated, the error was generated by the cached files that was created under /wp-content folder by the W3 Total Cache plugin. I have deleted these files(advanced-cache.php), and /cache, /w3tc-config folders. Now your menus works fine.

    These deleted files will be re-created once you enable the cache plugin, and configure it, so it should be good for now.

    Please check, and let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.