Whitelist specific browsers

I want to whitelist specific browser versions and perhaps redirect visitors using all the rest.

Not sure how to add new browsers or versions to this plugin and the author is unreachable. http://wordpress.org/extend/plugins/browser-blocker. Can anyone clarify how I would add something like Firfefox Aurora to it's list? I've tried copying the way all other browsers were added but with no luck. I believe it is because it can't detect the difference when 'Firefox" is still part of the name even though it is a completely different version and project ( versions are supposed to be supported) . I have to know if this is wordpress itself that can't detect the difference between FF's projects. I've found an extensive detection library , http://chrisschuld.com/projects/browser-php-detecting-a-users-browser-from-php/

Would need to add redirection and a " do this for all else " type of code to this plugin. http://wordpress.org/extend/plugins/php-browser-detection/

  • Kimberly
    • Champion of Loops

    Annabelle,

    Hi and Thanks for using WPMUdev forums!

    I'll move this to Advanced Wordpress discussion since it seems that you are needing to recode the plugin. Perhaps you will find a member dev that will be willing to look into this.

    Unfortunately recoding is beyond the scope of what the support staff can provide on the forums (unless you catch Tim on a good day!) :slight_smile:

    Best of luck in your project!

    Best,

    Kimberly

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.