whmcs 7 support

hi,
which versions of whmcs are compatible with the plugin?
i have a new server with php7 and i have to upgrade whmcs to version 7 beta in order to have support for ioncube.
will it work?
thanks