WHMCS Integration - Empty Cart & Other Errors


I'm having trouble with the WHMCS Integration plugin, which, until recently (within the last couple of months at least) used to work fine.

I seem to be having two different problems that as far as I can tell relate to whether or not the product being selected in the sales process provides domain options:

If you use this link - https://www.wmdstudios.co.uk/whmcs/whmcsportal/cart.php/?gid=6

1. Choose the "Free Forever" product
- As soon as you hit the configure screen, the order summary displays "An Error Occurred. Please Try Again." and you can't proceed past this point

2. Go back and choose either of the other products
- You then presented with the domain purchase / transfer / use own options. Do any of these and continue
- As soon as you hit the shopping cart you get the message "Your Shopping Cart is Empty" and you cannot proceed

Can you please help here?

Support access enabled.

  • Dimitris

    Hey there Dominic,

    hope you're doing good and thanks for reaching us!

    I presume that this was working until recently and there were no changes in settings of either WHMCS or WHMCS Integration plugin.

    Could you please try to make the same steps directly from WHMCS? Are you able to do so?

    If this isn't a matter of WHMCS, then clear/disable all of your caches, like plugins, server side services, 3rd party services like CloudFlare, and give it another try.

    If still in trouble, please proceed with a theme/plugin conflict test as described in a nice flow chat here
    (just scroll down a little to see the flow chart image)

    I look forward for your results on this! :slight_smile:

    Warm regards,

  • Adam Czajczyk

    Hello Dominic!

    Thank you for your response!

    We were experiencing some slight issues recently with WHMCS integration and our developers are working on a fix however I'm not yet sure whether it's the same issue or a new one. To be able to confirm that I'd like to ask you to enable WP debugging on the site. Please add following line to the "wp-config.php":


    This line should be placed above the "/* That's all, stop editing! */ line and once it's there, please go through the steps to replicate the issue again and see if there are any errors/warnings thrown to the screen. If so, let me know about them please.

    If there's no errors, please replace the line that I mentioned above with this code:


    and recreate the issue again. A "debug.log" file should appear inside the "/wp-content" folder of your site so please download it, rename it to "debug.txt" and attach to your replay here.

    I hope this will help me diagnose the case.

    Best regards,

  • Dominic

    Hi Adam,

    There are errors being produced:

    Warning: file_get_contents(/my-server-path/wp-content/plugins/whmcs-wordpress-integration/cache/e07a43d964dda820db4b7a33148b0264.txt): failed to open stream: No such file or directory in /my-server-path/wp-content/plugins/whmcs-wordpress-integration/includes/class-whmcs-wordpress-integration.php on line 376

    The file "e07a43d964dda820db4b7a33148b0264.txt" is indeed non existent.

    Also, I should point out that I get these errors on any WHMCS page and not just while re-producing my issue. There doesn't seem to be any additional errors produced when carrying out the steps that I described.

    I have however noticed that when visiting the home page (only, doesn't happen anywhere else) I am getting this error:

    Notice: Undefined index: pagename in /my-server-path/wp-content/plugins/whmcs-wordpress-integration/includes/class-whmcs-wordpress-integration.php on line 1029


  • Adam Czajczyk

    Hello Dominic!

    The first error confirms what I suspected, that this seems to be the issue I mentioned. Please check this post and give that solution a try:


    There are two "hot fix" files included along with installation instruction. Let me know please if this helps.

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.