WHMCS Integration not working with WHMCS Addon Module link method

WHMCS Integration plugin doesn't work with WHMCS Addon Module link Thanks for a great plugin - been fantastic! Were a few bugs when I first started using it, but hasn't had an issue since! Thanks :slight_smile:

I'm working on my site and found a WHMCS Addon Module that I'm trying to implement that would save me time/money by not having to constantly have customers contact me and have their (or their customers) IP address removed from the firewall. The problem I'm encountering is with a free addon module called WHMCS CSF Manager, by these folks: http://www.jetserver.net. I *do* understand that 3rd party modules aren't necessarily supported, but this seems to be a simple link problem from what I can see - sorry in advance if I'm mistaken. I did read another article in the community section here, hoping this is different. :wink:

In short, this allows the customer, from within their WHMCS account pages, to remove, block, etc. an IP address from the server without root intervention. The files are uploaded into the WHMCS /modules/addons folder and then activated in WHMCS > Addons > Jetserver CSF Manager. After this is done, I then follow the only directions given by the developers to integrate into my template/site:

Integrating CSF Manager into your client's area is very simple. Since this is an addon module, there is no need to make template changes besides adding a link to the module. All you need to do is to access your client area through the following URL -

example.com/index.php?m=csfmanager

Template & CSS Stracture are based on WHMCS default template (and the latest bootstrap.css file).

Therein lies the problem. I tried using the WHMCS integration plugin "Encode this URL" to place a link in the actual header.tpl file in the WHMCS template itself, but to no avail. No matter *how* I put the link, it failed. On my live site, I currently have the following settings:

Remote WHMCS Host: https://members.mypchost.com/
Default Content Page: My Account
Endpoint Slug: active

My primary site is located here: http://mypchost.com/

Now, using their link on the subdomain where my WHMCS is installed, works perfectly. Unfortunately, you have to be logged in to see the entire layout of the link, but you can at least GET to it here: https://members.mypchost.com/index.php?m=csfmanager

So my direct link to the whmcs integration plugin by you guys would be: http://mypchost.com/my-account/active/

Everything works fine except that "module" link and everything I tried below fails as well. I tried to format the link to look like their example, but nothing seems to work because the WPMUDev plugin reverts back to the url with the endpoint slug, preventing the page from loading that module.

These are what I tried and all failed.

/index.php?m=csfmanager
index.php?m=csfmanager
?m=csfmanager
m=csfmanager

Any help would be greatly appreciated here.... thanks in advance!!!

All the best,
Matt