WHMCS Integration Plugin Doesn't Work!

I just bought the WHMCS WP Integration plugin from yourself, installed it into my Wordpress site (http://z01.co.uk) and when I attempt to link it to my WHMCS installation (http://oracle.z01.co.uk) by entering its location into Remote WHMCS Host text area of the plugin's control panel, I get the following error message on clicking Save.

I get this if I enter the address as http://oracle.z01.co.uk

Fatal error: Call to undefined function mb_strrchr() in /home/z01/public_html/wp-content/plugins/whmcs-wordpresss-integration/lib/url_to_absolute.php on line 119

If I enter the address as oracle.z01.co.uk, I just get the settings saved message however if I visit http://z01.co.uk/my-account/ which includes your integration shortcode I get the following error on page:

WHMCS Integration: A valid URL was not provided.

Also it would appear that the address hasn't been saved to the plugins control panel.

If this plugin isn't going to work I want a refund or a fix immediately.

Thanks

JB

  • T3Kaos
    • Design Lord, Child of Thor

    I have resolved this myself. I rebuild my Apache to include php_mbscript successfully. It should be noted that this is a know issue with this plugin however no additional notes have been added to the plugins ReadMe files whatsoever. This should be changed forthwith.

  • PC
    • WPMU DEV Initiate

    Hello T3Kaos,

    Thanks for posting on the forums and being a great WPMU DEV Member :slight_smile:

    The suggestion has been duly noted and I am going to forward it to the developer for his feedback on the same.

    PS : Thanks for coming back and marking this as resolved. A few points coming your way !

    Cheers
    PC

  • T3Kaos
    • Design Lord, Child of Thor

    Thanks. I did however make a mistake. Your plugin requires php_mbstring to function. If you have direct control of your server you can add this functionality the following way, providing you are using cPanel/WHM.

    1) Open cPanel/WHM
    2) Select Software > EasyApache (ApacheUpdate)
    3) Select Start customising based on profile
    4) Select Next Step
    5) Select Next Step
    6) Exhaustive Options List
    7) Tick Mbstring checkbox and then select Save and build
    8) Allow Apache to Rebuild

    ENJOY!

  • kenlyle
    • Site Builder, Child of Zeus

    Thanks to T3Kaos. I agree, it would be great if requirements were documented in the readme or perhaps even in the plugin during install, maybe a Test button in the plugin, a requirements checking .php for the WHMCS and MU servers, something like that.

    From the report above, I am not sure whether T3Kaos is talking about the WHMCS server or the MU server.

    I just checked, and I do have mbstring installed on the WHMCS server, but am still getting this error.

    I also have
    mbstring
    Multibyte Support enabled
    Multibyte string engine libmbfl
    HTTP input encoding translation disabled

    on the MU server. Is that last the actual requirement, enabled?

    The unique thing is that I am using a cPanel temp URL http://IP/~username/dirname/

    Thanks for any clarifications.

  • kenlyle
    • Site Builder, Child of Zeus

    Ok, I have a partial solution...

    On the other thread:

    The ones that throw the: "WHMCS Integration: A valid URL was not provided." error are the templates below...

    1. Comparison
    2. Modern
    3. Slider

    In WHMCS on the Ordering tab, under Setup - General Settings

  • T3Kaos
    • Design Lord, Child of Thor

    Because of the lack of specification on the plugin, I have recently discontinued its use and moved over to a more complete integration using the services of the guys at WHMCSThemes.com. They did a great job for only $35. Hmmmm.....Interesting.....also working with any theme I have on my main WP site!

    Sorry guys for losing heart and giving up. :slight_frown:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.