WHMCS Integration: SSL certificate problem with error:14090086:

I'm getting the above errors. I have set the following

Remote WHMCS host;
https://firstchoicehosting.com/whmcs/

URL to encode;
https://firstchoicehosting.com/
(not sure if this is correct) as the result is still https://firstchoicehosting.com/

I have set the WHMCS system URL to https://firstchoicehosting.com

I have attached a screenshot of my WHMCS settings
http://firstchoicehosting.com/wp-content/uploads/2013/03/wpmudev-support-pic.jpg

I also have the Wordpress HTTPS plugin installed. Do I need to set the pages to force HTTPS .Is there some other way to make Wordpress use HTTPS?

Thanks for your help.

Regards
Leigh Connelly