WHMCS portal theme keeps showing.

Here is my problem: When a user goes to my site, they see the wordpress theme with the WHMCS links inside. When they go to click a link such as "Domain Checker" it will take them to the domain checker page but instead of seeing a wordpress theme they will now see the WHMCS portal theme/template.

I assumed when a user clicks the "Domain Checker" link within my wordpress theme it would just load that domain checker page within the same wordpress theme. Am I wrong in this assumption? Isn't that the point of the intergration plugin?

  • Timothy Bowers

    Hey there.

    Thanks for the question, but you've not provided any details about the set up, links for me to test? Screenshots of the settings?

    Did you also follow the inlign guidance?

    WHMCS WordPress Integration can now sync certain cookies between WHMCS and Wordpress so that downloads of protected files from WHMCS can work correctly in WordPress.

    This requires copying the "wp-integration.php" file in this plugin to the root of the WHMCS System installation.

    And can I also check that your Endpoint Slug is not the same as your WHMCS install because if it is then WHMCS would be installed there instead.

    Let me know.

    Take care.

  • Jordan

    Okay, I already had the "wp-integration.php" in the whmcs root folder. I believe the problem lies with my endpoint slug. My end point is "whmcs" which is also the folder where the whmcs is installed but if I change my enpoint slug to anything else, i mean anything, I always get Not Found errors when I click WHMCS related links like "Domain Checker".

    site: https://vonini.com

    whmcs: https://vonini.com/whmcs

  • Arnold

    You should pick an Endpoint that is diferent from whmcs which is where your actual WHMCS install is. Since the urls come out the same it can't tell whether you wan the WP or WHMCS site. It needs to be different.

    And how did you create your static Front page? Don't make a page with a slug for it that is /whmcs/ as well.

    For example make a page "My Account" slug = /my-account/
    Put your [wcp_content] shortcode on it.

    In settings > Reading set it to Static front page with the My Account page as the front page.

    It's a good idea to also rebuild your Permalinks by going to Permalinks and resaving them to force a build.

    Also don't use the default Permalink like page_id=345234. That turns off rewrite and doesn't work.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.