WHMCS Provisioning Pro Sites free level name

What should I put in a setting "ProSite Plan Name" to create a default free blog? It is not the same as in ProSites setings where is the option to change it. I allways get this Error: Invalid Pro Sites Level name in create_blog: Free:
"Free:" part changes to whatever is in a WHMCS Provisioning setting "ProSite Plan Name"

  • Ash
    • WordPress Hacker

    Hello @vitaljik

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    You need to use exactly same as Pro Site level name. In pro sites level the name is "Free"? I can see a colon (:slight_smile:, would you please try without colon in each settings?

    Cheers
    Ash

  • Tyler Postle
    • CGO

    Hey Vitaljik,

    Do you mind posting a screenshot of your product setup from WHMCS?

    Also, did you install the plugin directly from the WordPress dashboard? This could cause an error. Here is a possible solution that another user posted recently, similar problem was happening to him.

    Right, figured it out, I think.
    Installing the plugin from WP admin seems to have not unpacked properly.
    I downloaded the ZIP file locally and compared the contents. They were not the same. As soon I uploaded the correct files to WHMCS I had a Prosites field in the Module settings of the WHMCS product.

    Let us know if this helps! If not, post back and we'll continue to troubleshoot the issue :slight_smile:

    Thanks for being a member vitaljik!

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Vitaljik,

    Sounds like we're making some progress here!

    Okay, I'm thinking that since the FREE plan doesn't accept any sort of payment can you try switching that bottom option to: "Automatically setup the product as soon as the order is placed"? (the first option).

    Let me know if that works! If not, we'll continue to troubleshoot :slight_smile:

    All the best,
    Tyler

  • vitaljik
    • WPMU DEV Initiate

    Well, to make things more interesting, I have set a one time setup fee and that goes trough automatically. I have tried the first option as well before, and site is not created automatically :slight_frown:
    What is interesting, after order is paid but pending now. If I take this order to manage, default server selected is "none". If I select multisite server and click Accept order it goes trough and only then gives the mentioned error about nonexisting level. However, the site is created after this anyway.

    This is a first time (automatic creation intent) response:

    Array
    (
        [0] =>
        [1] => Array
            (
                [url] => HTTP://http://
                [content_type] =>
                [http_code] => 0
                [header_size] => 0
                [request_size] => 0
                [filetime] => -1
                [ssl_verify_result] => 0
                [redirect_count] => 0
                [total_time] => 0
                [namelookup_time] => 0
                [connect_time] => 0
                [pretransfer_time] => 0
                [size_upload] => 0
                [size_download] => 0
                [speed_download] => 0
                [speed_upload] => 0
                [download_content_length] => -1
                [upload_content_length] => -1
                [starttransfer_time] => 0
                [redirect_time] => 0
            )
    
        [2] => Connection Error: 6 - Couldn't resolve host 'http'
    )

    This is a second time (manual) response:

    Array
    (
        [0] => {"user_name":"supertes","install_type":"subdirectory","domain":"mydomain.es","path":"\/supertesto\/","login":"supertes","blog_id":47,"mapped_domain":"supertesto.mydomain.es","error":"Invalid Pro Sites Level name in create_blog: Basico"}
        [1] => Array
            (
                [url] => http://mydomain.es/
                [content_type] => text/html
                [http_code] => 200
                [header_size] => 811
                [request_size] => 926
                [filetime] => -1
                [ssl_verify_result] => 0
                [redirect_count] => 0
                [total_time] => 3.574572
                [namelookup_time] => 0.000382
                [connect_time] => 0.000793
                [pretransfer_time] => 0.001096
                [size_upload] => 683
                [size_download] => 228
                [speed_download] => 63
                [speed_upload] => 191
                [download_content_length] => -1
                [upload_content_length] => 683
                [starttransfer_time] => 3.467858
                [redirect_time] => 0
            )
    
        [2] =>
    )

    Ok, I found the difference between the Requests. First request for some reason is missing credentials. It must be like this (XXX´s my credentials) But in a request they are missing.

    Buser_login%5D=XXXXXX&whmcs%5Bcredentials%5D%5Buser_password%5D=XXXXXXXXXXXXXXXXXXXXXXXX&whmcs%5Bcredentials

  • aristath
    • Recruit

    Hello again @vitaljik, I hope you're well today!

    This issue is starting to get a little too technical... and it's now officially beyond our level of expertise.
    I have however notified our Second Level Support guys on this one (they're the code gurus), hopefully they'll be able to shed some more light here.

    Cheers,
    Ari.

  • Hoang Ngo
    • Code Slayer

    Hi @vitaljik,

    I hope you are well today and I'm sorry for the extra delay.

    I'm working with the developers about this issue, and we will include the fix for this in the future release :slight_smile:.

    Thanks for your patience and I'm very sorry about this inconvenience.

    Best regards,
    Hoang

  • Arnold
    • El Macho WP

    Actually the default for the automatic free level would be a blank Pro-Sites field on the WHMCS product definition.

    But that seems to confuse things.

    Give the attached version a try It will test against the Frre Name defined in settings and use 0 as the level if so. "0" is the default free level programmatically.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.