Whoops, looks like you skipped a step! Please go back and try again

I have installed latest version of WordPress and marketpress. I have set up the store. I keep on getting: “Whoops, looks like you skipped a step! Please go back and try again.” error when I fill in Paypal info or if I log in paypal to make the payment. I have tried the manual payment. There is no other plugin active. I have changed the session timeout to be 10000. I have read other threads and tried all the solutions. This issue is holding me back from the launch. Please advice.

  • aecnu
    • WP Unicorn

    Greetings priyanka1011 :slight_smile:

    are you referring to PayPal Express in Market Press or the PayPal Pro payment solution?

    and if it is PayPal Pro do you have a registered APP ID with x.com as required to use the PayPal Pro option?

    Joe :slight_smile:

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    As we haven’t heard back from you we’re going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn’t resolved, or you have any more questions related to this thread please feel free to post them below and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it’s a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Ok, then please provide us with answers to the questions asked above. Which PayPal gateway are you using? How is it setup? Do you have the required PayPal app ID? Is there anything in your IPN History?

    Let us know and we’ll be glad to assist. Thanks!

  • Mason
    • DEV MAN’s Sidekick

    I can see the issue on our site, but haven’t been able to reproduce it on any other install. I’ll ask the developer if he has any other thoughts here. Can you verify your WordPress version as well as version of this plugin please? Also, is there anything coming up in your php error logs?

    Thanks!

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    As we haven’t heard back from you we’re going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn’t resolved, or you have any more questions related to this thread please feel free to post them below and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it’s a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks

  • daveoutdoor
    • Flash Drive

    Hi everyone,

    I had it all working in my test environment, but when i moved the site to the live server I began getting the “Woops, looks like you skipped a step” error when I was returned to the site from PayPal to confirm the payment.

    After reading through the posts here on this issue i finally tracked it down to my server is changing the PayerID name and value to miniscule characters. Around line 270 of paypal-express.php it does a test for isset($_GET, and since it contains caps it was failing the test and throwing up the “woops” error.

    I changed it to isset($_GET … with lower-case chars… and it fixed the problem.

    Then the same thing happened with the Token ID: since it was converting caps to miniscule, it was not matching the real token test and would put up an “invalid token” error. I added another strtoupper() to the next two lines, like this:

    $_SESSION = strtoupper($_GET);

    $_SESSION = strtoupper($_GET);

    …and problem solved.

    I don’t know much about the current host, other than it’s running IIS and i really don’t like it :slight_smile: I assume that’s what is causing this issue in some way…

    Hope this helps someone else!

    Dave.

  • notme
    • Flash Drive

    I’m having this exact problem. I am using the Paypal Express API and after entering my credit card into PayPal I am returned to my site with the error:

    “Whoops, looks like you skipped a step! Please go back and try again.”

    I have tried switching the theme to TWENTYELEVEN., and that does not work.

    Using TWENTYELEVEN I disabled all other plugins and I still get the error message.

    I even bought the PRO version thinking it was a glitch in the free version.

    Please advise. Thanks. I do not understand exactly what daveoutdoor explained above.

  • notme
    • Flash Drive

    I have the answer to fix this problem.

    In some shared hosting environments you are not able to go above the root folder. However, in the default php.ini file, which can be edited in most shared hosting environments, the PHP sessions folder is above the root in /var/php_sessions. You will see this line in php.ini:

    session.save_path = “/var/php_sessions”

    1. In your file manager, create a folder at the highest level you possibly can and name it “php_sessions”

    2. Change the line mentioned above in your php.ini file to something like:

    session.save_path = “/home/users/web/some-other-id/your-root-folder/php_sessions”

    changing everything before the final /phpsessions to whatever your document root is.

  • BskBALL
    • New Recruit

    Hello

    We recently purchased the MarketPress plugin. We only need it to sell downloadable pdf reports. After setting everything up and went to do a test purchase (live) we are getting the same “Whoops” error.

    We are using PayPal Express checkout option, MarketPress plugin version 2.7

    WordPress version 3.3.1

    I have tried the caps/lowercase trick above but that just crashed the site. We are not on a shared server so the other option above doesn’t help either.

    Any help on this would be appreciated. Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.